Add default configuration file, init script, libpthread dependency (#1001)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 29 Nov 2006 13:29:23 +0000 (13:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 29 Nov 2006 13:29:23 +0000 (13:29 +0000)
SVN-Revision: 5677

net/privoxy/Makefile
net/privoxy/files/privoxy.config [new file with mode: 0644]
net/privoxy/files/privoxy.init [new file with mode: 0644]

index b4340b5b5d762b8e1b8cf57f1d28d8481e002dd3..659ae9ec70dce86a813ccd2ebe727cde981374b7 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/privoxy
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcre
+  DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
   DESCRIPTION:=Privoxy is a web proxy with advanced filtering capabilities for\\\
        protecting privacy, modifying web page content, managing cookies,\\\
@@ -76,8 +76,11 @@ define Build/Compile
 endef
 
 define Package/privoxy/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/privoxy 
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/privoxy  $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+       $(CP) ./files/$(PKG_NAME).config $(1)/etc/privoxy/config
+       $(CP) $(PKG_BUILD_DIR)/default.filter $(1)/etc/privoxy/
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,privoxy))
diff --git a/net/privoxy/files/privoxy.config b/net/privoxy/files/privoxy.config
new file mode 100644 (file)
index 0000000..9c0be4b
--- /dev/null
@@ -0,0 +1,22 @@
+confdir /etc/privoxy/
+logdir /var/log/
+actionsfile standard  # Internal purpose, recommended
+actionsfile default   # Main actions file
+actionsfile user      # User customizations
+filterfile default.filter
+logfile logfile
+jarfile jarfile
+trust-info-url  http://www.example.com/why_we_block.html
+trust-info-url  http://www.example.com/what_we_allow.html
+#admin-address privoxy-admin@example.com
+#proxy-info-url http://www.example.com/proxy-service.html
+debug   1    # show each GET/POST/CONNECT request
+debug   4096 # Startup banner and warnings
+debug   8192 # Errors - *we highly recommended enabling this*
+listen-address  127.0.0.1:8118
+toggle  1
+enable-remote-toggle  1
+enable-edit-actions 1
+permit-access  192.168.1.0/24
+buffer-limit 4096
+#hide-console
diff --git a/net/privoxy/files/privoxy.init b/net/privoxy/files/privoxy.init
new file mode 100644 (file)
index 0000000..7c9e018
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+conf=/etc/privoxy/config
+
+start() {
+        /usr/sbin/privoxy $conf
+}
+
+stop() {
+        killall privoxy
+}