[package] update lm-sensors to 3.1.1 (#5696)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 14 Aug 2009 15:17:27 +0000 (15:17 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 14 Aug 2009 15:17:27 +0000 (15:17 +0000)
SVN-Revision: 17263

utils/lm-sensors/Makefile

index 46e5689d95145a328eb68879e77707c1e55cf811..84b9fbaa2607c5a8539313d707a1968a2c00445a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lm-sensors
-PKG_VERSION:=3.0.2
+PKG_VERSION:=3.1.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=lm_sensors-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dl.lm-sensors.org/lm-sensors/releases/
-PKG_MD5SUM:=5b210ba9cc01f00161c438fd618484e5
+PKG_MD5SUM:=613d7cfa23b70c0abae3fabb0a72ff5f
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/lm_sensors-$(PKG_VERSION)
 
@@ -23,7 +23,7 @@ define Package/lm-sensors/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=lm-sensors
-  DEPENDS:=+sysfsutils @LINUX_2_6
+  DEPENDS:=+sysfsutils libsensors @LINUX_2_6
   URL:=http://www.lm-sensors.org/
 endef
 
@@ -48,6 +48,10 @@ define Package/libsensors/description
        lm-sensors libraries
 endef
 
+define Package/lm-sensors/conffiles
+/etc/sensors.conf
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                KERNELVERSION="$(LINUX_VERSION)" \
@@ -61,10 +65,10 @@ endef
 
 define Package/lm-sensors/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/prog/detect/sensors-detect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/detect/sensors-detect $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(CP) files/sensors.conf $(1)/etc/sensors.conf
+       $(INSTALL_CONF) ./files/sensors.conf $(1)/etc/sensors.conf
 endef
 
 define Package/libsensors/install