Add pipeviewer (#4257)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 28 Nov 2008 13:23:08 +0000 (13:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 28 Nov 2008 13:23:08 +0000 (13:23 +0000)
SVN-Revision: 13393

utils/pv/Makefile [new file with mode: 0644]

diff --git a/utils/pv/Makefile b/utils/pv/Makefile
new file mode 100644 (file)
index 0000000..a1094b6
--- /dev/null
@@ -0,0 +1,41 @@
+# 
+# Copyright (C) 2008 David Cooper, OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pv
+PKG_VERSION:=1.1.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://pipeviewer.googlecode.com/files/
+PKG_MD5SUM:=63033e090d61a040407bfd043aeb6d27
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pv
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Shell pipeline element to meter data passing through
+  URL:=http://www.ivarch.com/programs/pv.shtml
+endef
+
+define Package/pv/description
+ Pipe Viewer is a terminal-based tool for monitoring the progress of data
+ through a pipeline. It can be inserted into any normal pipeline between
+ two processes to give a visual indication of how quickly data is passing
+ through, how long it has taken, how near to completion it is, and an
+ estimate of how long it will be until completion.
+endef
+
+define Package/pv/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pv $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,pv))
+