[packages] openldap: remove unused ldif directory (#10712, thanks flyn), add missing...
authorStephen Walker <stephendwalker@gmail.com>
Tue, 24 Jan 2012 12:44:15 +0000 (12:44 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Tue, 24 Jan 2012 12:44:15 +0000 (12:44 +0000)
SVN-Revision: 29885

libs/openldap/Makefile
libs/openldap/patches/020-autofs-schema.patch

index dc0cc05362723e683f9306a76bcb8febd632bd7d..3cb124d46fb11adecb33b101a86fbc43c29089ea 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2011 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.23
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
@@ -28,6 +28,11 @@ define Package/openldap/Default
   MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 endef
 
+define Package/openldap/Default/description
+       OpenLDAP Software is an open source implementation of the
+       Lightweight Directory Access Protocol (LDAP).
+endef
+
 define Package/libopenldap
   $(call Package/openldap/Default)
   SECTION:=libs
@@ -37,8 +42,7 @@ define Package/libopenldap
 endef
 
 define Package/libopenldap/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains the shared LDAP client libraries, needed by other programs.
 endef
 
@@ -55,8 +59,7 @@ define Package/openldap-utils
 endef
 
 define Package/openldap-utils/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains client programs required to access LDAP servers.
 endef
 
@@ -64,13 +67,12 @@ define Package/openldap-server
   $(call Package/openldap/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenldap
+  DEPENDS:=+libopenldap +libuuid
   TITLE+= (server)
 endef
 
 define Package/openldap-server/description
-       OpenLDAP Software is an open source implementation of the 
-       Lightweight Directory Access Protocol (LDAP).   
+       $(call Package/openldap/Default/description)
        This package contains server programs required to provide LDAP services.
 endef
 
@@ -113,25 +115,24 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libopenldap/install
        $(INSTALL_DIR) $(1)/etc/openldap
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
 endef
-       
+
 define Package/openldap-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
 endef
-       
+
 define Package/openldap-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
-       $(INSTALL_DIR) $(1)/etc/openldap/ldif
        $(INSTALL_DIR) $(1)/etc/openldap/schema
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
index 093270fc72da2e8c117e06e7743013b066b4900e..11c73f5551b37b819d4befb80890032f2bde68bb 100644 (file)
@@ -5,21 +5,21 @@
 +      DESC 'Automount map name'
 +      EQUALITY caseExactMatch
 +      SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
-+                      
++
 +attributetype ( 1.3.6.1.1.1.1.32 NAME 'automountKey'
 +      DESC 'Automount key value'
 +      EQUALITY caseExactMatch
 +      SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
-+                      
++
 +attributetype ( 1.3.6.1.1.1.1.33 NAME 'automountInformation'
 +      DESC 'Automount information'
 +      EQUALITY caseExactMatch
 +      SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
-+                      
++
 +objectclass ( 1.3.6.1.1.1.2.16 NAME 'automountMap' SUP top STRUCTURAL
 +      MUST ( automountMapName )
 +      MAY ( description ) )
-+                                      
++
 +objectclass ( 1.3.6.1.1.1.2.17 NAME 'automount' SUP top STRUCTURAL
 +      DESC 'Automount'
 +      MUST ( automountKey $ automountInformation )