net/usbip: fix compile issue under SDK, refresh patches
authorAlexandros C. Couloumbis <alex@ozo.com>
Tue, 7 Dec 2010 15:19:55 +0000 (15:19 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Tue, 7 Dec 2010 15:19:55 +0000 (15:19 +0000)
SVN-Revision: 24306

net/usbip/Makefile
net/usbip/patches/000-upstream_svn_152.patch

index 1af6e7ed83a75d03418bcbe2358075e44ccaef8e..818ee4f9feca013ebdbfe00ec10fd2456fb07765 100644 (file)
@@ -93,9 +93,14 @@ LIBTOOL_PATHS:=./src
 
 CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
 
 
 CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
 
+TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include/
+TARGET_LDFLAGS+=-L$(STAGING_DIR)/usr/lib/libintl/lib/
+TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libiconv/include/
+TARGET_LDFLAGS+=-L$(STAGING_DIR)/usr/lib/libiconv/lib/
+
 define Build/Prepare
 $(call Build/Prepare/Default)
 define Build/Prepare
 $(call Build/Prepare/Default)
-       (cd $(PKG_BUILD_DIR)/src; ./autogen.sh )
+       (cd $(PKG_BUILD_DIR)/src; autoreconf -v --install || exit 1 )
 endef
 
 define Build/Compile/kmod
 endef
 
 define Build/Compile/kmod
index 115b32a9268da89b108a23569399441d360ee60c..e7135a66cef079cd172e7297be88c5403876d194 100644 (file)
@@ -79,8 +79,6 @@
  
 --- a/drivers/head/usbip_common.c
 +++ b/drivers/head/usbip_common.c
  
 --- a/drivers/head/usbip_common.c
 +++ b/drivers/head/usbip_common.c
- #define DRIVER_DESC "usbip common driver"
 @@ -55,10 +55,7 @@ static ssize_t show_flag(struct device *
  static ssize_t store_flag(struct device *dev, struct device_attribute *attr,
                const char *buf, size_t count)
 @@ -55,10 +55,7 @@ static ssize_t show_flag(struct device *
  static ssize_t store_flag(struct device *dev, struct device_attribute *attr,
                const char *buf, size_t count)