iputils: add missing includes, fix musl support
authorFelix Fietkau <nbd@openwrt.org>
Sun, 3 Aug 2014 10:45:36 +0000 (10:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Aug 2014 10:45:36 +0000 (10:45 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41958

package/network/utils/iputils/Makefile
package/network/utils/iputils/patches/020-include_fixes.patch [new file with mode: 0644]

index eeb6deb900c5845cfeb483989365d042c434fb6f..19061ca77ac574d2cf0322f119f83b9e6619e502 100644 (file)
@@ -121,10 +121,14 @@ define Package/iputils-traceroute6/description
   Traces path to a network host (IPv6).
 endef
 
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
+
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \
        CONFIG_IPV6="$(CONFIG_IPV6)" \
-       CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)" \
+       CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)$(CONFIG_USE_MUSL)" \
 
 define Package/iputils-arping/install
        $(INSTALL_DIR) $(1)/usr/bin
diff --git a/package/network/utils/iputils/patches/020-include_fixes.patch b/package/network/utils/iputils/patches/020-include_fixes.patch
new file mode 100644 (file)
index 0000000..0c97749
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/ping_common.h
++++ b/ping_common.h
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <sys/param.h>
+ #include <sys/socket.h>
+ #include <linux/sockios.h>
+@@ -24,6 +25,10 @@
+ #include "SNAPSHOT.h"
++#ifndef HZ
++#define HZ 100
++#endif
++
+ #define       DEFDATALEN      (64 - 8)        /* default data length */
+ #define       MAXWAIT         10              /* max seconds to wait for response */
+--- a/clockdiff.c
++++ b/clockdiff.c
+@@ -13,8 +13,6 @@
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+-#define TSPTYPES
+-#include <protocols/timed.h>
+ #include <fcntl.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>