[brcm47xx] deselect wpad-mini in wl profile instead of adding it to all other profile...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Jun 2010 13:44:19 +0000 (13:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Jun 2010 13:44:19 +0000 (13:44 +0000)
SVN-Revision: 21852

target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
target/linux/brcm47xx/profiles/105-Atheros.mk
target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk

index eae5ca3e37337242382707446a0907da7af7fb67..56c87e482064a3c65521fc6a06194910025353a4 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb pcmcia
 LINUX_VERSION:=2.6.32.14
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
+DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 12421800924b3ac378c5a5e2121741cf2702f1d7..df8d37baff619c75379e36d0d0d9375cf51bfe88 100644 (file)
@@ -6,8 +6,8 @@
 #
 
 define Profile/Broadcom-b43
-  NAME:=Broadcom BCM43xx WiFi - "b43" driver (default)
-  PACKAGES:=wpad-mini kmod-b43 kmod-b43legacy
+  NAME:=Broadcom BCM43xx WiFi (b43, default)
+  PACKAGES:=kmod-b43 kmod-b43legacy
 endef
 
 define Profile/Broadcom-b43/Description
index 4cfb089eab1bab1660aafb0f0e9961abdc884e32..d67298cc9dcdd63f712a6e59df112e6a523803ce 100644 (file)
@@ -6,8 +6,8 @@
 #
 
 define Profile/Broadcom-wl
-  NAME:=Broadcom BCM43xx WiFi - "wl" driver (proprietary)
-  PACKAGES:=kmod-brcm-wl wlc nas
+  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 889f4bc74f4b35a80ce633e080612d1ce2335c38..46046a1fa56240040b5c0ce8b274c77d937bef19 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 define Profile/Atheros
-  NAME:=Atheros WiFi
+  NAME:=Atheros WiFi (madwifi)
   PACKAGES:=kmod-madwifi
 endef
 
index 2dea0d542106670cbd77a2d52ae064e0cf8a3381..bf8630388e2f8d6af4fb825d5d65ca8808bb5434 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 define Profile/WL500GPv1
-  NAME:=ASUS WL-500g Premium v1 (Atheros WiFi)
+  NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using madwifi)
   PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-uhci kmod-usb2
 endef