Update zabbix to 2.2.2
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 18:32:49 +0000 (18:32 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 18:32:49 +0000 (18:32 +0000)
refresh patch (patch configure.ac instead of .in)
zabbix-agentd tested on wr1043nd
zabbix-* compile tested

zabbix-extra-wifi discovery still not working
(need an suid helper to make ubus calls)

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>
SVN-Revision: 40639

admin/zabbix/Makefile
admin/zabbix/patches/001-cross_compile.patch
admin/zabbix/patches/002-fix-res_send-on-uclibc.patch
admin/zabbix/patches/010-change-agentd-config.patch

index 9c53810baa107b2c66af85d5705693f0df0fd430..99a7d01becf7109a91b86ad71f320713af411b03 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zabbix
-PKG_VERSION:=2.2.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/zabbix
-PKG_MD5SUM:=558497839b13a548f533eb2fc951a4e3
+PKG_MD5SUM:=7f680ad3ef7145840e3de5c7a0f19b7c
 
 PKG_INSTALL:=1
 
index cf8b6d83ff7bb9b52069c3b74e3c1ad0eb0a84b2..26132c818227c049e732ea6d6eea91943c62e4d0 100644 (file)
@@ -1,6 +1,6 @@
---- a/configure.in
-+++ b/configure.in
-@@ -804,25 +804,8 @@ dnl ************************************
+--- a/configure.ac
++++ b/configure.ac
+@@ -805,25 +805,8 @@ dnl ************************************
  
  dnl Check for %qu format (FreeBSD 4.x)
  dnl FreeBSD 4.x does not support %llu
index 7072f03630209b1d11a5ee09e1c0d89f09db0004..95b37b1aec054b16169d6b2d54a4ec33affa6102 100644 (file)
@@ -1,6 +1,6 @@
---- a/configure.in
-+++ b/configure.in
-@@ -151,6 +151,10 @@ if test "x$found_resolv" != "xyes"; then
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,6 +152,10 @@ if test "x$found_resolv" != "xyes"; then
        AC_MSG_ERROR([Unable to do DNS lookups (libresolv check failed)])
  fi
  LIBS="${LIBS} ${RESOLV_LIBS}"
  dnl *                                                               *
 --- a/src/libs/zbxsysinfo/common/net.c
 +++ b/src/libs/zbxsysinfo/common/net.c
-@@ -421,6 +421,7 @@ static int dns_query(AGENT_REQUEST *requ
#else /* not _WINDOWS */
-       res_init();     /* initialize always, settings might have changed */
+@@ -424,6 +424,7 @@ static int dns_query(AGENT_REQUEST *requ
      if (-1 == res_init())   /* initialize always, settings might have changed */
+               return SYSINFO_RET_FAIL;
  
 +#if defined(HAVE_RES_MKQUERY) && defined(HAVE_RES_SEND) 
        if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
                return SYSINFO_RET_FAIL;
  
-@@ -439,6 +440,11 @@ static int        dns_query(AGENT_REQUEST *requ
+@@ -448,6 +449,11 @@ static int        dns_query(AGENT_REQUEST *requ
        _res.retry = retry;
  
        res = res_send(buf, res, answer.buffer, sizeof(answer.buffer));
@@ -31,5 +31,5 @@
 +      return SYSINFO_RET_FAIL;
 +#endif 
  
-       hp = (HEADER *)answer.buffer;
+       _res.retrans = saved_retrans;
+       _res.retry = saved_retry;
index cf5083e2439a3d16d740378b1303db1facebea02..ce584fbb5c81c5c26cc2ed82fc433bd69af788f5 100644 (file)
@@ -48,8 +48,8 @@
 -Hostname=Zabbix server
 -
  ### Option: HostnameItem
- #     Item used for generating Hostname if it is undefined.
- #     Ignored if Hostname is defined.
+ #     Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
+ #     Does not support UserParameters or aliases.
 @@ -240,7 +231,7 @@ Hostname=Zabbix server
  # Include=