firewall: Improve ubus support
authorSteven Barth <cyrus@openwrt.org>
Wed, 23 Oct 2013 10:25:26 +0000 (10:25 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 23 Oct 2013 10:25:26 +0000 (10:25 +0000)
* Use network.interface dump call instead of individual status calls
  to reduce overall netifd lookups and invokes to 1 per fw3 process.

* Allow protocol handlers to assign a firewall zone for an interface
  in the data section to allow for dynamic firewall zone assignment.

SVN-Revision: 38504

package/network/config/firewall/Makefile
package/network/config/firewall/files/firewall.hotplug

index 0d495117d4bee8641069848fb7689f56931b44c0..ac4d16a388a6a82a040d6f4e818bbc3b5555e04d 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_VERSION:=2013-10-10
+PKG_VERSION:=2013-10-23
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fca5e39564e488b169c8c535dcf658649f81429e
+PKG_SOURCE_VERSION:=c25922c05ae594c4c35fa65f27fd21c3a033f4ec
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
index 34f3afec9b5466e4fa75cdc7cd71c01ad53e0d5d..20a95d4363d2677ac20c33c9155f4375c630d82e 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-[ "$ACTION" = ifup ] || exit 0
+[ "$ACTION" = ifup -o "$ACTION" = ifupdate ] || exit 0
 
 /etc/init.d/firewall enabled || exit 0