[packages] remove usages of $(CONFIG_LARGEFILE) and $(DISABLE_LARGEFILE)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Jan 2011 16:59:47 +0000 (16:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Jan 2011 16:59:47 +0000 (16:59 +0000)
SVN-Revision: 25207

ipv6/dibbler/Makefile
libs/db47/Makefile
libs/ossp-js/Makefile
libs/postgresql/Makefile
libs/rrdtool-1.0.x/Makefile
net/elinks/Makefile
net/lighttpd/Makefile
net/openssh/Makefile
net/samba/Makefile
net/samba3/Makefile

index 419f8ef5c6d0686c5942890d29d9a7a0bf6737cf..6a2a4431ce0b056c409b8f2a1f840bf7a047913f 100644 (file)
@@ -101,7 +101,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
        );
 endef
 
index c309e06728ee41ab587a5317fac3097edfcba8dd..7c38f2333dce5ce9d2e62c8f2585bcaba5542391 100644 (file)
@@ -60,7 +60,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
                        --disable-java \
index 5af55f6392ac0b6ab259762feb03777912e67fe9..78ddb7978cb5864d0d0ea8f5d95faa0a9e06ebd1 100644 (file)
@@ -69,7 +69,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --disable-shared \
                        --enable-static \
        );
index 7f15de92c06ff796ba9aef4f2ebca37af714bcb5..2120155ad0264e59f774a293b15a6ad1b3b34d31 100644 (file)
@@ -77,7 +77,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
                        --disable-integer-datetimes \
index c14fcb5516db6b9921617255e354459f10a3f9f6..4e0eebc5c854831d39adf584cbe14c8b436f0f9c 100644 (file)
@@ -85,7 +85,6 @@ endef
 TARGET_CFLAGS += $(FPIC) --std=c99
 
 CONFIGURE_ARGS += \
-       $(DISABLE_LARGEFILE) \
        $(DISABLE_NLS) \
        --enable-shared=yes \
        --enable-static=yes \
index db2970c092d21c6510c6c2a7ff2a7c2fe3246202..caaefea3eb8172b39eaa680c762f8cab99fa2931 100644 (file)
@@ -60,7 +60,6 @@ define Build/Configure
                         --mandir=/usr/share/man \
                         --sbindir=/usr/sbin \
                         --sysconfdir=/etc \
-                        $(DISABLE_LARGEFILE) \
                         $(DISABLE_NLS) \
                         --enable-small\
                         --enable-256-colors\
index cd5ffbd5fc598a29728fee18754c3080f8796832..9b344cce5a0fd658462f8dc35d055f64cc6f244f 100644 (file)
@@ -229,11 +229,6 @@ CONFIGURE_ARGS+= \
 CONFIGURE_VARS+= \
        PCRE_LIB="-lpcre" \
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  CONFIGURE_ARGS+= \
-       --disable-lfs
-endif
-
 ifeq ($(CONFIG_IPV6),y)
   CONFIGURE_ARGS+= \
        --enable-ipv6
index 8a3ee695741ecce6ced1eedea3c89e05fd9abd6f..beb16c90c25df850ec9f07e689e5c0e05fb647c3 100644 (file)
@@ -110,7 +110,6 @@ OpenSSH SFTP server.
 endef
 
 CONFIGURE_ARGS+= \
-       $(DISABLE_LARGEFILE) \
        $(DISABLE_NLS) \
        --sysconfdir=/etc/ssh \
        --enable-shared \
index 7f2dd04581d5cdf6bbdf0f036666696c7d988a5e..1fc09cf8aacff0c7c4b71cd1623132e6cee7bdb8 100644 (file)
@@ -73,7 +73,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -144,7 +143,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
index dfdcb19ac34ba6a7753709223f4175b8b9f7cd0f..3ff3ec542d4c32ec3a85a990d2ef17034ffa7505 100644 (file)
@@ -40,11 +40,9 @@ define Package/samba3/config
        source "$(SOURCE)/Config.in"
 endef
 
-ifneq ($(CONFIG_LARGEFILE),)
-  define Build/Prepare/LFS
+define Build/Prepare/LFS
        cat ./files/config-lfs.h >> $(PKG_BUILD_DIR)/source/include/config.h
-  endef
-endif
+endef
 
 define Build/Prepare
 $(call Build/Prepare/Default)