toolchain/gdb: fix compile for powerpc targets, refresh patch
authorFelix Fietkau <nbd@openwrt.org>
Sat, 11 Jun 2011 13:25:00 +0000 (13:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 11 Jun 2011 13:25:00 +0000 (13:25 +0000)
SVN-Revision: 27155

toolchain/gdb/patches/100-ppc_compile_fix.patch [new file with mode: 0644]
toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch

diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
new file mode 100644 (file)
index 0000000..4c5cb4e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+       $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+ run: psim
index 124b3cce2c31e6a819824836ba837f923b9382d0..089ab8c5a5b7537d264b9ad2cb30fb1f1696d617 100644 (file)
@@ -1,7 +1,5 @@
-Index: openwrt/dl/gdb-7.2/gdb/configure
-===================================================================
---- gdb-7.2/gdb/configure
-+++ gdb-7.2/gdb/configure
+--- a/gdb/configure
++++ b/gdb/configure
 @@ -988,7 +988,7 @@ CPP
  YACC
  YFLAGS
 @@ -988,7 +988,7 @@ CPP
  YACC
  YFLAGS
@@ -11,7 +9,7 @@ Index: openwrt/dl/gdb-7.2/gdb/configure
  gdbtk
  multi-ice
  gdbserver'
  gdbtk
  multi-ice
  gdbserver'
-@@ -7880,7 +7880,7 @@ fi
+@@ -7881,7 +7881,7 @@ fi
  
  
  
  
  
  
@@ -20,11 +18,9 @@ Index: openwrt/dl/gdb-7.2/gdb/configure
  
  
  # Check whether to support alternative target configurations
  
  
  # Check whether to support alternative target configurations
-Index: openwrt/dl/gdb-7.2/gdb/gdbserver/configure
-===================================================================
---- gdb-7.2/gdb/gdbserver/configure
-+++ gdb-7.2/gdb/gdbserver/configure
-@@ -2151,7 +2151,7 @@ $as_echo "$as_me: error: \`$ac_var' was 
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -2152,7 +2152,7 @@ $as_echo "$as_me: error: \`$ac_var' was 
        ac_cache_corrupted=: ;;
      ,);;
      *)
        ac_cache_corrupted=: ;;
      ,);;
      *)