more fixes for the V= stuff
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 10:54:33 +0000 (10:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 10:54:33 +0000 (10:54 +0000)
SVN-Revision: 2225

openwrt/package/bind/Makefile
openwrt/package/libdb/Makefile

index 934c582b8d63853b6e3b97e526f8402f1d8c9ed7..eeb428ac305fbabf9c954617cc1c3d6c6681599b 100644 (file)
@@ -20,7 +20,7 @@ include $(TOPDIR)/package/rules.mk
 $(eval $(call PKG_template,BIND_SERVER,bind-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,BIND_CLIENT,bind-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(strip $(TARGET_CFLAGS))" \
@@ -55,7 +55,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
                CC="$(HOSTCC)" \
                CFLAGS="-O2" \
@@ -65,7 +65,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
-       touch $(PKG_BUILD_DIR)/.built
+       touch $@
 
 $(IPKG_BIND_SERVER):
        install -d -m0755 $(IDIR_BIND_SERVER)/usr/sbin
index 77510aefe98756ffa3661d5d48bbf58c54f2ff9e..0fc8687b580bdb63aef2bd922158cfd4d0658f0f 100644 (file)
@@ -19,7 +19,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBDB,libdb,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR)/build_unix ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -61,14 +61,14 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        );
        touch $@
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/build_unix \
                DESTDIR="$(PKG_INSTALL_DIR)" install
        touch $@
 
-$(IPKG_LIBDB): $(STAGING_DIR)/usr/lib/libdb.so
+$(IPKG_LIBDB): 
        install -m0755 -d $(IDIR_LIBDB)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libdb*.so $(IDIR_LIBDB)/usr/lib/
        $(RSTRIP) $(IDIR_LIBDB)
@@ -87,5 +87,5 @@ uninstall-dev:
        rm -rf $(STAGING_DIR)/usr/include/db.h
        rm -rf $(STAGING_DIR)/usr/lib/libdb*.{a,so}
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev