use variable KERNEL
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sat, 10 Sep 2005 16:34:08 +0000 (16:34 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sat, 10 Sep 2005 16:34:08 +0000 (16:34 +0000)
SVN-Revision: 1886

openwrt/target/linux/image/brcm/Makefile

index 634aaeeb3d85e65586fe3491c84df5c9ee93fbfc..abba13101f0048bd707d2bf04bab61d9d45d75a0 100644 (file)
@@ -30,11 +30,11 @@ $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
 ifeq ($(KERNEL),2.6)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
 
-$(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+$(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        dd if=$(BUILD_DIR)/loader.elf of=$@ bs=131072 conv=sync
        cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
 
-install: $(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin
+install: $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
 endif
 
 ifeq ($(KERNEL),2.4)