[packages_10.03.2] hd-idle: merge r30722
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 16:19:03 +0000 (16:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 16:19:03 +0000 (16:19 +0000)
SVN-Revision: 30723

utils/hd-idle/Makefile
utils/hd-idle/files/hd-idle.init

index 25fb32e97dfa98450eddfc6b79674c1821005eaa..6e9b950e89eaebbdbe00e3f4a8e821db9697dbb4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hd-idle
 PKG_VERSION:=1.03
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index eb2db35e32470d1b7f176f38318ad1072c64dcc3..1abf2325f5815bab01f91ab29fd4b9cc43b8f266 100644 (file)
@@ -63,11 +63,11 @@ start_service() {
        args=""
        config_get "interval" "$section" "idle_time_interval"
        config_get "unit" "$section" "idle_time_unit"
-       append_string "$section" "disk" "-t"
+       append_string "$section" "disk" "-a"
        append_bool "$section" "enable_debug" "-d"
        config_get_bool "enabled" "$section" "enabled" '1'
        [ "$enabled" -gt 0 ] || return 1
-       service_start /usr/bin/hd-idle -i "$(compute_seconds $interval $unit)" $args
+       service_start /usr/bin/hd-idle $args -i "$(compute_seconds $interval $unit)"
 }
 
 start() {