[magicbox] update to 2.6.26
authorGabor Juhos <juhosg@openwrt.org>
Fri, 1 Aug 2008 19:34:37 +0000 (19:34 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 1 Aug 2008 19:34:37 +0000 (19:34 +0000)
SVN-Revision: 12066

target/linux/magicbox/Makefile
target/linux/magicbox/config-default
target/linux/magicbox/patches/001-magicbox_support.patch
target/linux/magicbox/patches/100-cf_slot.patch

index d539f98f4c72d6428ca125c9ebbd8a7fa1ea6eca..a804184d1aa86237c9751c35611bac3dfd531981 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24.7
+LINUX_VERSION:=2.6.26
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index cb43f3434b7f2f45d611da5e246c552f7bd45d0b..d63e83ddf8be5266c38076220a5e2f147e7599c7 100644 (file)
@@ -5,51 +5,59 @@ CONFIG_4xx=y
 # CONFIG_6xx is not set
 # CONFIG_8139TOO is not set
 # CONFIG_8xx is not set
+# CONFIG_ACCESSIBILITY is not set
 # CONFIG_ADVANCED_OPTIONS is not set
 # CONFIG_AGP is not set
+CONFIG_ARCH_HAS_ILOG2_U32=y
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
 CONFIG_ARCH_MAY_HAVE_PC_FDC=y
 CONFIG_ARCH_POPULATES_NODE_MAP=y
-# CONFIG_ATM_DRIVERS is not set
-# CONFIG_B44 is not set
+# CONFIG_ARCH_SUPPORTS_MSI is not set
 CONFIG_BASE_SMALL=0
 CONFIG_BIOS_FIXUP=y
-# CONFIG_BLK_DEV_FD is not set
-# CONFIG_BLK_DEV_HD is not set
+CONFIG_BITREVERSE=y
+# CONFIG_BLK_DEV_HD_ONLY is not set
 CONFIG_BLK_DEV_IDE=m
-# CONFIG_BLK_DEV_IDECD is not set
 CONFIG_BLK_DEV_IDEDISK=m
 # CONFIG_BLK_DEV_IDEDMA is not set
-# CONFIG_BLK_DEV_IDEFLOPPY is not set
-# CONFIG_BLK_DEV_IDEPCI is not set
-# CONFIG_BLK_DEV_IDESCSI is not set
-# CONFIG_BLK_DEV_IDETAPE is not set
-# CONFIG_BLK_DEV_IDE_SATA is not set
 CONFIG_BLK_DEV_MAGICBOX_IDE=y
 # CONFIG_BOOKE_WDT is not set
 CONFIG_BOOT_LOAD=0x00400000
+CONFIG_BOUNCE=y
 # CONFIG_BT is not set
 # CONFIG_BUBINGA is not set
+CONFIG_CLASSIC_RCU=y
 CONFIG_CMDLINE="root=/dev/mtdblock1 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200 init=/etc/preinit"
 CONFIG_CMDLINE_BOOL=y
 CONFIG_CONSISTENT_SIZE=0x00200000
 CONFIG_CONSISTENT_START=0xff100000
 # CONFIG_CPCI405 is not set
 # CONFIG_CPU_FREQ is not set
-# CONFIG_E200 is not set
-# CONFIG_E500 is not set
+CONFIG_CRYPTO_AEAD=m
+CONFIG_CRYPTO_AUTHENC=m
+CONFIG_CRYPTO_GF128MUL=m
+# CONFIG_DEBUG_BUGVERBOSE is not set
+CONFIG_DEVPORT=y
+# CONFIG_DMADEVICES is not set
 # CONFIG_EDAC is not set
 # CONFIG_EP405 is not set
-# CONFIG_FIRMWARE_EDID is not set
 CONFIG_FS_POSIX_ACL=y
+CONFIG_GENERIC_BUG=y
+# CONFIG_GENERIC_FIND_FIRST_BIT is not set
 CONFIG_GENERIC_FIND_NEXT_BIT=y
 CONFIG_GENERIC_NVRAM=y
 # CONFIG_GEN_RTC is not set
+CONFIG_HAS_DMA=y
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+# CONFIG_HAVE_DMA_ATTRS is not set
+CONFIG_HAVE_IDE=y
+CONFIG_HAVE_KPROBES=y
+# CONFIG_HAVE_KRETPROBES is not set
+CONFIG_HAVE_OPROFILE=y
 # CONFIG_HIGHMEM is not set
 CONFIG_HIGHMEM_START=0xfe000000
 CONFIG_HW_RANDOM=y
-CONFIG_HZ=100
-CONFIG_HZ_100=y
-# CONFIG_HZ_250 is not set
 # CONFIG_I2C is not set
 CONFIG_IBM_EMAC=y
 # CONFIG_IBM_EMAC_DEBUG is not set
@@ -59,27 +67,31 @@ CONFIG_IBM_EMAC_RXB=64
 CONFIG_IBM_EMAC_RX_COPY_THRESHOLD=256
 CONFIG_IBM_EMAC_RX_SKB_HEADROOM=0
 CONFIG_IBM_EMAC_TXB=8
+# CONFIG_IBM_NEW_EMAC_EMAC4 is not set
+# CONFIG_IBM_NEW_EMAC_RGMII is not set
+# CONFIG_IBM_NEW_EMAC_TAH is not set
+# CONFIG_IBM_NEW_EMAC_ZMII is not set
 CONFIG_IBM_OCP=y
 CONFIG_IDE=m
-# CONFIG_IDEDISK_MULTI_MODE is not set
-# CONFIG_IDEDMA_AUTO is not set
-# CONFIG_IDE_ARM is not set
 CONFIG_IDE_GENERIC=m
-CONFIG_IDE_MAX_HWIFS=4
 # CONFIG_IDE_PROC_FS is not set
-# CONFIG_IDE_TASK_IOCTL is not set
 CONFIG_INITRAMFS_SOURCE=""
+CONFIG_IPV6_NDISC_NODETYPE=y
 CONFIG_ISA_DMA_API=y
+# CONFIG_IWLWIFI_LEDS is not set
 CONFIG_KERNEL_START=0xc0000000
-# CONFIG_KEXEC is not set
-# CONFIG_LEDS_TRIGGER_IDE_DISK is not set
+# CONFIG_LEDS_ALIX is not set
 CONFIG_LOWMEM_SIZE=0x30000000
+CONFIG_LZO_COMPRESS=m
+CONFIG_LZO_DECOMPRESS=m
 # CONFIG_MACINTOSH_DRIVERS is not set
 CONFIG_MAGICBOX=y
 CONFIG_MATH_EMULATION=y
-CONFIG_MINI_FO=y
+# CONFIG_MEDIA_ATTACH is not set
+# CONFIG_MEMSTICK is not set
 CONFIG_MTD=y
 # CONFIG_MTD_ABSENT is not set
+CONFIG_MTD_BLKDEVS=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_MTD_BLOCK2MTD is not set
 CONFIG_MTD_CFI=y
@@ -113,7 +125,6 @@ CONFIG_MTD_MAP_BANK_WIDTH_2=y
 CONFIG_MTD_MAP_BANK_WIDTH_4=y
 # CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
 # CONFIG_MTD_MTDRAM is not set
-# CONFIG_MTD_OBSOLETE_CHIPS is not set
 # CONFIG_MTD_ONENAND is not set
 # CONFIG_MTD_OTP is not set
 CONFIG_MTD_PARTITIONS=y
@@ -131,46 +142,60 @@ CONFIG_MTD_PHYSMAP_START=0xffc00000
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_NATSEMI is not set
 # CONFIG_NE2K_PCI is not set
-# CONFIG_NET_VENDOR_3COM is not set
 # CONFIG_NETDEV_1000 is not set
+# CONFIG_NET_VENDOR_3COM is not set
 CONFIG_NOT_COHERENT_CACHE=y
 # CONFIG_NVRAM is not set
-# CONFIG_PCIPCWATCHDOG is not set
+# CONFIG_OCF_OCF is not set
+CONFIG_PAGEFLAGS_EXTENDED=y
 CONFIG_PCI=y
+# CONFIG_PCIPCWATCHDOG is not set
 CONFIG_PCI_DOMAINS=y
+CONFIG_PCI_SYSCALL=y
 # CONFIG_PC_KEYBOARD is not set
-# CONFIG_PM is not set
 CONFIG_PPC=y
 CONFIG_PPC32=y
 CONFIG_PPC4xx_DMA=y
 CONFIG_PPC4xx_EDMA=y
+CONFIG_PPC_DCR=y
+CONFIG_PPC_DCR_NATIVE=y
 CONFIG_PPC_GEN550=y
 # CONFIG_PPC_I8259 is not set
 CONFIG_PPC_INDIRECT_PCI=y
 CONFIG_PPC_OCP=y
+# CONFIG_R6040 is not set
 # CONFIG_REDWOOD_5 is not set
 # CONFIG_REDWOOD_6 is not set
+CONFIG_RFKILL_LEDS=y
 CONFIG_RWSEM_XCHGADD_ALGORITHM=y
+# CONFIG_SCHED_HRTICK is not set
 CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
-# CONFIG_SCSI_BUSLOGIC is not set
-# CONFIG_SCSI_EATA is not set
-# CONFIG_SCSI_GDTH is not set
-# CONFIG_SECCOMP is not set
+CONFIG_SCSI_WAIT_SCAN=m
 # CONFIG_SERIAL_8250_EXTENDED is not set
 # CONFIG_SERIAL_TEXT_DEBUG is not set
+CONFIG_SLABINFO=y
 # CONFIG_SOFT_WATCHDOG is not set
 # CONFIG_SOUND is not set
 # CONFIG_SPARSEMEM_STATIC is not set
+# CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
+CONFIG_SSB_POSSIBLE=y
 # CONFIG_SYCAMORE is not set
+CONFIG_SYSVIPC_SYSCTL=y
 CONFIG_TASK_SIZE=0x80000000
+# CONFIG_THERMAL is not set
+# CONFIG_THERMAL_HWMON is not set
 CONFIG_UART0_TTYS0=y
 # CONFIG_UART0_TTYS1 is not set
-# CONFIG_UNUSED_SYMBOLS is not set
-# CONFIG_USER_NS is not set
+# CONFIG_VGASTATE is not set
 # CONFIG_VIA_RHINE is not set
+CONFIG_VIDEO_ALLOW_V4L1=y
+CONFIG_VIDEO_MEDIA=m
+CONFIG_VIDEO_V4L1=m
+CONFIG_VIDEO_V4L2=m
+CONFIG_VIDEO_V4L2_COMMON=m
 # CONFIG_WALNUT is not set
 CONFIG_WANT_EARLY_SERIAL=y
-# CONFIG_WINDFARM is not set
+CONFIG_WORD_SIZE=32
 # CONFIG_XILINX_ML300 is not set
 # CONFIG_XILINX_ML403 is not set
 # CONFIG_XILINX_SYSACE is not set
index 5d8c3448bcff7e9af96dd164943e8057e573a82d..fe1221392f8ee8b58ddd67ec809e7ea91dfd0c66 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/arch/ppc/platforms/4xx/Kconfig
-+++ linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
-@@ -53,6 +53,12 @@ config WALNUT
+--- a/arch/ppc/platforms/4xx/Kconfig
++++ b/arch/ppc/platforms/4xx/Kconfig
+@@ -53,6 +53,12 @@
        help
          This option enables support for the IBM PPC405GP evaluation board.
  
@@ -15,7 +13,7 @@ Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
  config XILINX_ML300
        bool "Xilinx-ML300"
        select XILINX_VIRTEX_II_PRO
-@@ -184,7 +190,7 @@ config BOOKE
+@@ -184,7 +190,7 @@
  
  config IBM_OCP
        bool
@@ -24,7 +22,7 @@ Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
        default y
  
  config IBM_EMAC4
-@@ -194,7 +200,7 @@ config IBM_EMAC4
+@@ -194,7 +200,7 @@
  
  config BIOS_FIXUP
        bool
@@ -33,7 +31,7 @@ Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
        default y
  
  # OAK doesn't exist but wanted to keep this around for any future 403GCX boards
-@@ -205,7 +211,7 @@ config 403GCX
+@@ -205,7 +211,7 @@
  
  config 405EP
        bool
@@ -42,11 +40,9 @@ Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
        default y
  
  config 405GP
-Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/ppc/platforms/4xx/Makefile
-+++ linux-2.6.24.7/arch/ppc/platforms/4xx/Makefile
-@@ -14,6 +14,7 @@ obj-$(CONFIG_REDWOOD_6)              += redwood6.o
+--- a/arch/ppc/platforms/4xx/Makefile
++++ b/arch/ppc/platforms/4xx/Makefile
+@@ -14,6 +14,7 @@
  obj-$(CONFIG_SYCAMORE)                += sycamore.o
  obj-$(CONFIG_TAISHAN)         += taishan.o
  obj-$(CONFIG_WALNUT)          += walnut.o
@@ -54,10 +50,8 @@ Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Makefile
  obj-$(CONFIG_XILINX_ML300)    += xilinx_ml300.o
  obj-$(CONFIG_XILINX_ML403)    += xilinx_ml403.o
  
-Index: linux-2.6.24.7/include/asm-ppc/ibm4xx.h
-===================================================================
---- linux-2.6.24.7.orig/include/asm-ppc/ibm4xx.h
-+++ linux-2.6.24.7/include/asm-ppc/ibm4xx.h
+--- a/include/asm-ppc/ibm4xx.h
++++ b/include/asm-ppc/ibm4xx.h
 @@ -19,6 +19,10 @@
  
  #ifdef CONFIG_40x
index ca7ca4e6216264c4392f0f4a37c9c3288aa82770..e15d522df81f7c65910111ca6b69b52d50add580 100644 (file)
@@ -1,30 +1,18 @@
-Index: linux-2.6.24.7/drivers/ide/ide.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/ide.c
-+++ linux-2.6.24.7/drivers/ide/ide.c
-@@ -1563,6 +1563,7 @@ done:
- extern void __init pnpide_init(void);
- extern void __exit pnpide_exit(void);
- extern void __init h8300_ide_init(void);
-+extern void __init ide_magicbox_init(void);
+--- a/drivers/ide/ide.c
++++ b/drivers/ide/ide.c
+@@ -494,6 +494,9 @@
  
- /*
-  * probe_for_hwifs() finds/initializes "known" IDE interfaces
-@@ -1627,6 +1628,9 @@ static void __init probe_for_hwifs (void
- #ifdef CONFIG_H8300
-       h8300_ide_init();
+       return -EPERM;
  #endif
 +#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
 +      ide_magicbox_init();
 +#endif
  }
  
- /*
-Index: linux-2.6.24.7/drivers/ide/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Kconfig
-+++ linux-2.6.24.7/drivers/ide/Kconfig
-@@ -1018,6 +1018,14 @@ config BLK_DEV_MPC8xx_IDE
+ int set_pio_mode(ide_drive_t *drive, int arg)
+--- a/drivers/ide/Kconfig
++++ b/drivers/ide/Kconfig
+@@ -928,6 +928,14 @@
  
          If unsure, say N.
  
@@ -39,15 +27,10 @@ Index: linux-2.6.24.7/drivers/ide/Kconfig
  choice
        prompt "Type of MPC8xx IDE interface"
        depends on BLK_DEV_MPC8xx_IDE
-Index: linux-2.6.24.7/drivers/ide/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Makefile
-+++ linux-2.6.24.7/drivers/ide/Makefile
-@@ -37,6 +37,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE)    += leg
- # built-in only drivers from ppc/
- ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
- ide-core-$(CONFIG_BLK_DEV_IDE_PMAC)   += ppc/pmac.o
-+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE)       += ppc/magicbox_ide.o
+--- a/drivers/ide/ppc/Makefile
++++ b/drivers/ide/ppc/Makefile
+@@ -1,3 +1,4 @@
  
- # built-in only drivers from h8300/
- ide-core-$(CONFIG_IDE_H8300)          += h8300/ide-h8300.o
+ obj-$(CONFIG_BLK_DEV_IDE_PMAC)                += pmac.o
+ obj-$(CONFIG_BLK_DEV_MPC8xx_IDE)      += mpc8xx.o
++obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE)    += magicbox_ide.o