Package wpa-passphrase (#1275)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 16 Sep 2007 10:32:42 +0000 (10:32 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 16 Sep 2007 10:32:42 +0000 (10:32 +0000)
SVN-Revision: 8788

package/wpa_supplicant/Makefile

index 6448145565bf2ed0c25dfd78fe64cb5bbb7d2ded..a90196868c7f811ceb249626676dbbb07073c7c4 100644 (file)
@@ -27,7 +27,6 @@ define Package/wpa-supplicant
   URL:=http://hostap.epitest.fi/wpa_supplicant/
 endef
 
-
 define Package/wpa-cli
   SECTION:=net
   CATEGORY:=Network
@@ -36,6 +35,13 @@ define Package/wpa-cli
   DESCRIPTION:=
 endef
 
+define Package/wpa-passphrase
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=wpa-supplicant
+  TITLE:=Set WPA passphrase for a SSID
+  DESCRIPTION:=
+endef
 
 define Build/Configure
        cp ./files/config.$(ARCH) $(PKG_BUILD_DIR)/.config
@@ -65,5 +71,11 @@ define Package/wpa-cli/install
        $(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
 endef
 
+define Package/wpa-passphrase/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wpa_passphrase $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,wpa-supplicant))
 $(eval $(call BuildPackage,wpa-cli))
+$(eval $(call BuildPackage,wpa-passphrase))