kernel: revert r24160 (remove the bogus ext2/ext3 dependency on linux 2.6.30/31)
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 13 Apr 2011 13:37:40 +0000 (13:37 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 13 Apr 2011 13:37:40 +0000 (13:37 +0000)
For kernel versions newer then 2.6.31 the ext4 module can be used to mount
ext2/3 filesystems.
Building ext2/3 as modules on the other hand breaks using ext4 for mounting ext2
or ext3, which breaks booting from ext2/3 on machines where the ext4 module is
built into the kernel.

SVN-Revision: 26645

package/kernel/modules/fs.mk

index 8b619f7475bcedcf8221efdc967313c583035a6f..c0df23f5085e4bd1ecc0e7c192a0db1c3381daba 100644 (file)
@@ -76,7 +76,7 @@ define KernelPackage/fs-ext2
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT2 filesystem support
   KCONFIG:=CONFIG_EXT2_FS
-  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
   FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
   AUTOLOAD:=$(call AutoLoad,32,ext2,1)
 endef
@@ -94,7 +94,7 @@ define KernelPackage/fs-ext3
   KCONFIG:= \
        CONFIG_EXT3_FS \
        CONFIG_JBD
-  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
   FILES:= \
        $(LINUX_DIR)/fs/ext3/ext3.ko \
        $(LINUX_DIR)/fs/jbd/jbd.ko