brcm63xx: Add DT support for 96348GW-11
authorJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:07 +0000 (12:25 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:07 +0000 (12:25 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42731

target/linux/brcm63xx/dts/bcm96348GW-11.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm96348GW-11.dts b/target/linux/brcm63xx/dts/bcm96348GW-11.dts
new file mode 100644 (file)
index 0000000..906ecab
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Broadcom BCM96348GW-11 reference board";
+       compatible = "brcm,bcm96348gw-11", "brcm,bcm6348";
+};
index ddd24358ea12c9cc2afc024935d6310f2c34b513..f234314999988a401f05521c4d036dad47f1622c 100755 (executable)
@@ -237,7 +237,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348R,6348,96348R-generic,,)
        $(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
        $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
-       $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-generic)
        $(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
        $(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
@@ -344,6 +343,8 @@ $(eval $(call CfeImageDTB,96348GW,bcm96348GW,96348GW,6348,96348GW-generic))
 $(eval $(call CfeImageDTB,96348GW,bcm96348GW,96348GW,6348,96348GW-bc221,,--layoutver 5))
 # Generic 96348GW-10
 $(eval $(call CfeImageDTB,96348GW_10,bcm96348GW-10,96348GW-10,6348,96348GW-10-generic))
+# Generic 96348GW-11
+$(eval $(call CfeImageDTB,96348GW_11,bcm96348GW-11,96348GW-11,6348,96348GW-11-generic))
 
 # ADB P.DG A4001N
 $(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
index a8b3424eff3222b3a23f61d514323c6552ee68a5..88335a1f569588c91287edc760b088c8b8bb10de 100644 (file)
@@ -49,3 +49,12 @@ define Profile/96348GW_10/Description
   Package set optimized for 96348GW-10.
 endef
 $(eval $(call Profile,96348GW_10))
+
+define Profile/96348GW_11
+  NAME:=Generic 96348GW-11
+  PACKAGES:=
+endef
+define Profile/96348GW_11/Description
+  Package set optimized for 96348GW-11.
+endef
+$(eval $(call Profile,96348GW_11))