[package] opkg: add upstream patch fixing the order packages are configured (closes...
authorNicolas Thill <nico@openwrt.org>
Sat, 3 Apr 2010 21:38:17 +0000 (21:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 3 Apr 2010 21:38:17 +0000 (21:38 +0000)
SVN-Revision: 20686

package/opkg/Makefile
package/opkg/patches/000-upstream-fix_configure_order.patch [new file with mode: 0644]

index 6894ae7cb445a71d87faa9aceca93f02789c2d91..81f7b4a4a02ba03447a27fc60a1ac50e0650ab61 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=opkg
 PKG_REV:=513
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/opkg/patches/000-upstream-fix_configure_order.patch b/package/opkg/patches/000-upstream-fix_configure_order.patch
new file mode 100644 (file)
index 0000000..dcd1b54
--- /dev/null
@@ -0,0 +1,15 @@
+http://code.google.com/p/opkg/source/detail?r=521
+
+--- a/libopkg/opkg_cmd.c
++++ b/libopkg/opkg_cmd.c
+@@ -390,8 +390,8 @@ opkg_configure_packages(char *pkg_name)
+            goto error;
+      }
+     
+-     for(i = 0; i < all->len; i++) {
+-        pkg = all->pkgs[i];
++     for(i = 0; i < ordered->len; i++) {
++        pkg = ordered->pkgs[i];
+         if (pkg_name && fnmatch(pkg_name, pkg->name, 0)) 
+              continue;