add memtester
authorImre Kaloz <kaloz@openwrt.org>
Sun, 9 Dec 2007 17:19:39 +0000 (17:19 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sun, 9 Dec 2007 17:19:39 +0000 (17:19 +0000)
SVN-Revision: 9688

utils/memtester/Makefile [new file with mode: 0644]

diff --git a/utils/memtester/Makefile b/utils/memtester/Makefile
new file mode 100644 (file)
index 0000000..6b70385
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=memtester
+PKG_VERSION:=4.0.8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pyropus.ca/software/memtester/old-versions/
+PKG_MD5SUM:=a4971ed1ccaf5b2e2148fd66b0eb7363
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/memtester
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Userspace utility for testing the memory subsystem for faults
+  URL:=http://pyropus.ca/software/memtester/
+endef
+
+define Package/memtester/description
+ A userspace utility for testing the memory subsystem for faults.
+endef
+
+define Build/Configure
+       $(SED) 's,cc -O2,$(TARGET_CC) $(TARGET_CFLAGS),' $(PKG_BUILD_DIR)/conf-cc
+       $(SED) "s,cc,$(TARGET_CC)," $(PKG_BUILD_DIR)/conf-ld
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
+define Package/memtester/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/memtester $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,memtester))