[packages] openssh: update to v5.2p1 (partially closes: #4780, thanks to puchu)
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 23:36:04 +0000 (23:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 23:36:04 +0000 (23:36 +0000)
SVN-Revision: 15462

net/openssh/Makefile
net/openssh/patches/100-no_cast_fix.patch
net/openssh/patches/110-no_ripemd_fix.patch
net/openssh/patches/130-implicit_memset_decl_fix.patch [new file with mode: 0644]

index 23ea57524c122adb2b9734301529fccdc0d6cfa8..84bca8b8dbd6923f21387299480402105917db8f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=5.0p1
+PKG_VERSION:=5.2p1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
                ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
                ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=1f1dfaa775f33dd3328169de9bdc292a
+PKG_MD5SUM:=ada79c7328a8551bdf55c95e631e7dad
 
 PKG_BUILD_DEPENDS:=libopenssl
 
index c0ed6c9c4b398db7ec65df2f32778ec835442cbf..dfcf0d0875d2a65722508e528994c9a689f257e8 100644 (file)
@@ -1,12 +1,12 @@
 --- a/cipher.c
 +++ b/cipher.c
-@@ -72,7 +72,9 @@
+@@ -73,7 +73,9 @@ struct Cipher {
  
-       { "3des-cbc",           SSH_CIPHER_SSH2, 8, 24, 0, EVP_des_ede3_cbc },
-       { "blowfish-cbc",       SSH_CIPHER_SSH2, 8, 16, 0, EVP_bf_cbc },
+       { "3des-cbc",           SSH_CIPHER_SSH2, 8, 24, 0, 1, EVP_des_ede3_cbc },
+       { "blowfish-cbc",       SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_bf_cbc },
 +#ifndef OPENSSL_NO_CAST
-       { "cast128-cbc",        SSH_CIPHER_SSH2, 8, 16, 0, EVP_cast5_cbc },
+       { "cast128-cbc",        SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_cast5_cbc },
 +#endif
-       { "arcfour",            SSH_CIPHER_SSH2, 8, 16, 0, EVP_rc4 },
-       { "arcfour128",         SSH_CIPHER_SSH2, 8, 16, 1536, EVP_rc4 },
-       { "arcfour256",         SSH_CIPHER_SSH2, 8, 32, 1536, EVP_rc4 },
+       { "arcfour",            SSH_CIPHER_SSH2, 8, 16, 0, 0, EVP_rc4 },
+       { "arcfour128",         SSH_CIPHER_SSH2, 8, 16, 1536, 0, EVP_rc4 },
+       { "arcfour256",         SSH_CIPHER_SSH2, 8, 32, 1536, 0, EVP_rc4 },
index 6276b0a5384092929bf30accdfbf0ea8d64b6bdd..35bd0ba93e7c68c4de8406046528bca12db81382 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mac.c
 +++ b/mac.c
-@@ -59,8 +59,10 @@
+@@ -59,8 +59,10 @@ struct {
        { "hmac-sha1-96",               SSH_EVP, EVP_sha1, 96, -1, -1 },
        { "hmac-md5",                   SSH_EVP, EVP_md5, 0, -1, -1 },
        { "hmac-md5-96",                SSH_EVP, EVP_md5, 96, -1, -1 },
diff --git a/net/openssh/patches/130-implicit_memset_decl_fix.patch b/net/openssh/patches/130-implicit_memset_decl_fix.patch
new file mode 100644 (file)
index 0000000..c4644df
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/includes.h
++++ b/includes.h
+@@ -56,6 +56,9 @@
+ /*
+  *-*-nto-qnx needs these headers for strcasecmp and LASTLOG_FILE respectively
+  */
++#ifdef HAVE_STRING_H
++# include <string.h>
++#endif
+ #ifdef HAVE_STRINGS_H
+ # include <strings.h>
+ #endif