Updated libpcap to 0.9.4, tcpdump to 3.9.4
authorFlorian Fainelli <florian@openwrt.org>
Sun, 5 Feb 2006 17:30:49 +0000 (17:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 5 Feb 2006 17:30:49 +0000 (17:30 +0000)
SVN-Revision: 3139

openwrt/package/libpcap/Makefile
openwrt/package/libpcap/patches/100-shared-lib.patch
openwrt/package/libpcap/patches/101-cross-compile-fix.patch
openwrt/package/libpcap/patches/102-alt-ether.patch
openwrt/package/tcpdump/Makefile
openwrt/package/tcpdump/patches/remove-pcap-debug.patch

index 670bca0cdbf5e168284dd0f0956b1b044ed168ab..67bc3f7fdc3a34f05574a17db14add781d8058d0 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
-PKG_VERSION:=0.8.3
-PKG_RELEASE:=2
-PKG_MD5SUM:=56a9d4615d8354fcfe8cff8c8443c77b
+PKG_VERSION:=0.9.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=79025766e8027df154cb1f32de8a7974
 
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index fbbef5b674a69346337163e4190620749a523b5c..54cc774a3760d311d7c391b67d02d48487a1736c 100644 (file)
@@ -1,12 +1,13 @@
---- libpcap-0.8.3-orig/Makefile.in     2003-12-15 02:42:23.000000000 +0100
-+++ libpcap-0.8.3-7/Makefile.in        2005-03-08 03:38:22.000000000 +0100
+diff -urN libpcap-0.9.4.orig/Makefile.in libpcap-0.9.4/Makefile.in
+--- libpcap-0.9.4.orig/Makefile.in     2003-12-15 02:35:03.000000000 +0100
++++ libpcap-0.9.4/Makefile.in  2006-02-05 16:56:18.000000000 +0100
 @@ -37,6 +37,15 @@
  srcdir = @srcdir@
  VPATH = @srcdir@
  
 +# some defines for shared library compilation
-+MAJ=0.8
-+MIN=3
++MAJ=0.9
++MIN=4
 +VERSION=$(MAJ).$(MIN)
 +LIBNAME=pcap
 +LIBRARY=lib$(LIBNAME).a
@@ -16,7 +17,7 @@
  #
  # You shouldn't need to edit anything below.
  #
-@@ -49,6 +58,7 @@
+@@ -50,6 +59,7 @@
  
  # Standard CFLAGS
  CFLAGS = $(CCOPT) $(INCLS) $(DEFS)
  
  INSTALL = @INSTALL@
  INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -68,7 +78,11 @@
- # problem if you don't own the file but can write to the directory.
+@@ -70,7 +80,12 @@
  .c.o:
        @rm -f $@
--      $(CC) $(CFLAGS) -c $(srcdir)/$*.c
+       $(CC) $(CFLAGS) -c $(srcdir)/$*.c
 +      $(CC) $(CFLAGS) -c -o $@ $(srcdir)/$*.c
-+
 +%_pic.o: %.c
 +      @rm -f $@
 +      $(CC) -fPIC $(CFLAGS) -c -o $@ $(srcdir)/$*.c
++      
  PSRC =        pcap-@V_PCAP@.c
  FSRC =  fad-@V_FINDALLDEVS@.c
-@@ -83,6 +97,7 @@
+ SSRC =  @SSRC@
+@@ -84,6 +99,7 @@
  # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
  # hack the extra indirection
  OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
@@ -45,7 +46,7 @@
  HDR = pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
        ethertype.h gencode.h gnuc.h
  GENHDR = \
-@@ -94,15 +109,22 @@
+@@ -95,15 +111,23 @@
  TAGFILES = \
        $(SRC) $(HDR) $(TAGHDR)
  
 +      ln -s $(SHAREDLIB) $(SOLIBRARY).$(MAJ)
 +      ln -s $(SOLIBRARY).$(MAJ) $(SOLIBRARY)
 +
- scanner.c: $(srcdir)/scanner.l
-       @rm -f $@
-       $(LEX) -t $< > $$$$.$@; mv $$$$.$@ $@
-@@ -110,6 +132,9 @@
++       
+ shared: libpcap.$(DYEXT)
+ #
+@@ -129,6 +153,10 @@
  scanner.o: scanner.c tokdefs.h
        $(CC) $(CFLAGS) -c scanner.c
  
 +scanner_pic.o: scanner.c tokdefs.h
 +      $(CC) -fPIC $(CFLAGS) -o $@ -c scanner.c
++
 +
  pcap.o: version.h
  
  tokdefs.h: grammar.c
-@@ -123,9 +148,17 @@
+@@ -142,9 +170,16 @@
        @rm -f $@
        $(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c
  
  
 +version_pic.o: version.c
 +      $(CC) -fPIC $(CFLAGS) -c version.c -o $@
-+
 +
  snprintf.o: $(srcdir)/missing/snprintf.c
        $(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
  
-@@ -151,10 +184,16 @@
+@@ -170,10 +205,17 @@
  bpf_filter.o: bpf_filter.c
        $(CC) $(CFLAGS) -c bpf_filter.c
  
 +bpf_filter_pic.o: bpf_filter.c
 +      $(CC) -fPIC $(CFLAGS) -c bpf_filter.c -o $@
 +
- install:
++
+ install: libpcap.a 
        [ -d $(DESTDIR)$(libdir) ] || \
            (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
        $(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a
index 196ee34eb3a293976bd3d76e33c99b990710477d..5ba78adaef6f9c380cc20834f3fe0473b1d09775 100644 (file)
@@ -1,6 +1,7 @@
---- libpcap-0.8.3/Makefile.in.orig     2005-01-17 19:04:41.291056960 -0500
-+++ libpcap-0.8.3/Makefile.in  2005-01-17 19:04:47.836061968 -0500
-@@ -100,7 +100,7 @@
+diff -urN libpcap-0.9.4.orig/Makefile.in libpcap-0.9.4/Makefile.in
+--- libpcap-0.9.4.orig/Makefile.in     2006-02-05 16:57:16.000000000 +0100
++++ libpcap-0.9.4/Makefile.in  2006-02-05 16:57:03.000000000 +0100
+@@ -117,7 +117,7 @@
  
  libpcap.a: $(OBJ)
        @rm -f $@
@@ -8,4 +9,4 @@
 +      $(AR) rc $@ $(OBJ) $(LIBS)
        $(RANLIB) $@
  
- scanner.c: $(srcdir)/scanner.l
+ $(SHAREDLIB): $(OBJ_PIC)
index d5e010ec678c2b992d80ffa181e19391577f0f56..347265d6e913a0ac4d9ab1779652a3de538f721c 100644 (file)
@@ -1,6 +1,7 @@
---- libpcap-0.8.3-orig/nametoaddr.c    2003-11-19 19:13:48.000000000 +0100
-+++ libpcap-0.8.3-7/nametoaddr.c       2005-03-08 03:38:22.000000000 +0100
-@@ -333,7 +333,7 @@
+diff -urN libpcap-0.9.4.orig/nametoaddr.c libpcap-0.9.4/nametoaddr.c
+--- libpcap-0.9.4.orig/nametoaddr.c    2005-04-20 13:13:51.000000000 +0200
++++ libpcap-0.9.4/nametoaddr.c 2006-02-05 16:58:46.000000000 +0100
+@@ -410,7 +410,7 @@
        e = ep = (u_char *)malloc(6);
  
        while (*s) {
                        s += 1;
                d = xdtoi(*s++);
                if (isxdigit((unsigned char)*s)) {
---- libpcap-0.8.3-orig/scanner.l       2004-03-28 23:45:33.000000000 +0200
-+++ libpcap-0.8.3-7/scanner.l  2005-03-08 03:38:22.000000000 +0100
+diff -urN libpcap-0.9.4.orig/scanner.l libpcap-0.9.4/scanner.l
+--- libpcap-0.9.4.orig/scanner.l       2005-09-05 11:08:07.000000000 +0200
++++ libpcap-0.9.4/scanner.l    2006-02-05 17:00:13.000000000 +0100
 @@ -80,6 +80,7 @@
  N             ([0-9]+|(0X|0x)[0-9A-Fa-f]+)
  B             ([0-9A-Fa-f][0-9A-Fa-f]?)
  W             ([0-9A-Fa-f][0-9A-Fa-f]?[0-9A-Fa-f]?[0-9A-Fa-f]?)
-+X             [0-9A-Fa-f]
++X               [0-9A-Fa-f]
  
  %a 16000
  %o 19000
-@@ -296,7 +297,7 @@
+@@ -306,7 +307,7 @@
  {N}                   { yylval.i = stoi((char *)yytext); return NUM; }
  ({N}\.{N})|({N}\.{N}\.{N})|({N}\.{N}\.{N}\.{N})       {
                        yylval.s = sdup((char *)yytext); return HID; }
                          return EID; }
  {V6}                  {
  #ifdef INET6
-@@ -314,6 +315,8 @@
+@@ -324,6 +325,7 @@
  #endif /*INET6*/
                        }
  {B}:+({B}:+)+         { bpf_error("bogus ethernet address %s", yytext); }
-+{X}{12}                       { yylval.e = pcap_ether_aton((char *)yytext); return EID;}
-+
++{X}{12}                        { yylval.e = pcap_ether_aton((char *)yytext); return EID;}
  icmptype              { yylval.i = 0; return NUM; }
  icmpcode              { yylval.i = 1; return NUM; }
  icmp-echoreply                { yylval.i = 0; return NUM; }
index fabd1500bbbc40de99afe1e4166ac3911467c459..b19c0efe4ed52e6f594891e5e6b8657a5881aac2 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpdump
-PKG_VERSION:=3.8.3
+PKG_VERSION:=3.9.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=30645001f4b97019677cad88d3811904
+PKG_MD5SUM:=4b64755bbc8ba1af49c747271a6df5b8
 
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
        http://ftp.gwdg.de/pub/misc/tcpdump/ \
index 7a0c9c3c21041f1c1661b30b7df646f007dad959..d8993f057aaa32401151d024ab54363a066e8e4d 100644 (file)
@@ -1,8 +1,8 @@
-diff -urN tcpdump-3.8.3.old/tcpdump.c tcpdump-3.8.3.dev/tcpdump.c
---- tcpdump-3.8.3.old/tcpdump.c        2004-03-17 20:47:48.000000000 +0100
-+++ tcpdump-3.8.3.dev/tcpdump.c        2005-04-29 00:53:20.000000000 +0200
-@@ -596,20 +596,6 @@
-                               error("invalid data link type %s", dlt_name);
+diff -urN tcpdump-3.9.4.orig/tcpdump.c tcpdump-3.9.4/tcpdump.c
+--- tcpdump-3.9.4.orig/tcpdump.c       2005-08-23 12:29:41.000000000 +0200
++++ tcpdump-3.9.4/tcpdump.c    2006-02-05 17:52:37.000000000 +0100
+@@ -762,20 +762,6 @@
+                               error("invalid data link type %s", gndo->ndo_dltname);
                        break;
  
 -#if defined(HAVE_PCAP_DEBUG) || defined(HAVE_YYDEBUG)
@@ -19,6 +19,6 @@ diff -urN tcpdump-3.8.3.old/tcpdump.c tcpdump-3.8.3.dev/tcpdump.c
 -                      }
 -                      break;
 -#endif
-               default:
-                       usage();
-                       /* NOTREACHED */
+               case 'Z':
+                       if (optarg) {
+                               username = strdup(optarg);