[packages] ffmpeg: add workarounds for build failure on x86
authorNicolas Thill <nico@openwrt.org>
Mon, 21 Dec 2009 02:11:06 +0000 (02:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 21 Dec 2009 02:11:06 +0000 (02:11 +0000)
SVN-Revision: 18869

multimedia/ffmpeg/Makefile

index 39c9e93bbd85f33b6e0599bd98882dfd63c9c3d2..05136af11672093ef83982173bddd343567dcc66 100644 (file)
@@ -163,6 +163,11 @@ FFMPEG_CONFIGURE_DEMUXERS:=$(call FILTER_CONFIG,DEMUXER,demuxer,$(FFMPEG_DEMUXER
 FFMPEG_CONFIGURE_PARSERS:=$(call FILTER_CONFIG,PARSER,parser,$(FFMPEG_PARSERS))
 FFMPEG_CONFIGURE_PROTOCOLS:=$(call FILTER_CONFIG,PROTOCOL,protocol,$(FFMPEG_PROTOCOLS))
 
+# XXX: add --disable-mmx & --disable-mmx2 to fix build failure on x86
+# libpostproc/postprocess_template.c:2195: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+# libpostproc/postprocess_template.c:3124: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+# libpostproc/postprocess_template.c:3207: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
@@ -180,6 +185,8 @@ define Build/Configure
                --enable-ffserver \
                --enable-gpl \
                --enable-libfaad \
+               --disable-mmx \
+               --disable-mmx2 \
                --enable-pthreads \
                --disable-optimizations \
                --enable-small \