[package] fix stunnel restart, bump makefile (#5897, #6220)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 12:14:16 +0000 (12:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 12:14:16 +0000 (12:14 +0000)
SVN-Revision: 18994

net/stunnel/Makefile
net/stunnel/files/stunnel.init

index ff16727c2a87c509402ca34b6498710a491b3495..4693305f37c94142c36a459d0b86abc48dcdf880 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
 PKG_VERSION:=4.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=14dc3f8412947f0548975cbce74d6863
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index f74ff680fb67d4f92d9acee26d084328a3b77395..a3ea1037f4715609d8108636a80d3fc1f47cb0a3 100644 (file)
@@ -26,5 +26,9 @@ start() {
 }
 
 stop() {
-       [ -f $PID_F ] && kill -9 $(cat $PID_F) && rm -f $PID_F
+       [ -f $PID_F ] && {
+               kill $(cat $PID_F)
+               kill -9 $(cat $PID_F)
+               rm -f $PID_F
+       }
 }