[packages] utils: add crypto-tools
authorGabor Juhos <juhosg@openwrt.org>
Tue, 18 Nov 2008 20:57:34 +0000 (20:57 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 18 Nov 2008 20:57:34 +0000 (20:57 +0000)
SVN-Revision: 13285

utils/crypto-tools/Makefile [new file with mode: 0644]

diff --git a/utils/crypto-tools/Makefile b/utils/crypto-tools/Makefile
new file mode 100644 (file)
index 0000000..d90a2e0
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=crypto-tools
+PKG_VERSION:=20080917
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/ocf-linux
+PKG_MD5SUM:=d20377afefa707fe528b161c2174e874
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DEPENDS:=libopenssl
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/crypto-tools
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libopenssl
+  TITLE:=OCF-Linux's crypto-tools
+endef
+
+define Build/Configure
+endef
+
+define Package/crypto-tools/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cryptotest $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cryptokeytest $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,crypto-tools))