[packages] add cups-bjnp, a CUPS backend for proprietary Canon printer protocol
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 7 Apr 2010 18:50:49 +0000 (18:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 7 Apr 2010 18:50:49 +0000 (18:50 +0000)
SVN-Revision: 20738

net/cups-bjnp/Makefile [new file with mode: 0644]

diff --git a/net/cups-bjnp/Makefile b/net/cups-bjnp/Makefile
new file mode 100644 (file)
index 0000000..4eab1c6
--- /dev/null
@@ -0,0 +1,45 @@
+# 
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cups-bjnp
+PKG_VERSION:=0.5.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/cups-bjnp
+PKG_MD5SUM:=4f29dd69a487a90ac7603b5be5cb030f
+
+PKG_BUILD_DEPENDS:=cups
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cups-bjnp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=BJNP protocol backend for CUPS
+  URL:=http://sourceforge.net/projects/cups-bjnp/
+  DEPENDS:=cups
+endef
+
+define Package/cups-bjnp/description
+CUPS backend for the canon printers using the proprietary USB over
+IP BJNP protocol. This backend allows Cups to print over the network
+to a Canon printer. It currently supports Cups 1.2 and Cups 1.3 and
+is designed by reverse engineering.
+endef
+
+TARGET_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/cups-bjnp/install
+       $(INSTALL_DIR) $(1)/usr/lib/cups/backend
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bjnp $(1)/usr/lib/cups/backend
+endef
+
+
+$(eval $(call BuildPackage,cups-bjnp))