[avr32] generate LZMA compressed uImage as well
authorGabor Juhos <juhosg@openwrt.org>
Fri, 23 May 2008 09:09:16 +0000 (09:09 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 23 May 2008 09:09:16 +0000 (09:09 +0000)
SVN-Revision: 11249

target/linux/avr32/image/Makefile

index cbaf07dfb38577a0834566280dededef73296dba..2cef2653bf1db6b0d3554e74219fc9b42346bb5a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -22,6 +22,14 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+       mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
+               -e 0x90000000 \
+               -n 'OpenWrt Linux-$(LINUX_VERSION)' \
+               -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage-lzma
+
+       cp $(KDIR)/uImage-lzma $(BIN_DIR)/openwrt-$(BOARD)-uImage-lzma
 endef
 
 define Image/Build