[ar71xx] add experimental support for the Linksys WRT400N board (thanks to netprince)
authorGabor Juhos <juhosg@openwrt.org>
Sun, 26 Apr 2009 06:40:02 +0000 (06:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 26 Apr 2009 06:40:02 +0000 (06:40 +0000)
SVN-Revision: 15422

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/config-2.6.29
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wrt400n.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h

index 15c6159e1b1f11216e84de018e103cdbbe42113b..fb0ff2746269c522f457571a277dcd5beba8a061 100755 (executable)
@@ -52,6 +52,9 @@ ar71xx_board_name() {
        *WNR2000)
                name="wnr2000"
                ;;
        *WNR2000)
                name="wnr2000"
                ;;
+       *WRT400N)
+               name="wrt400n"
+               ;;
        *)
                name="generic"
                ;;
        *)
                name="generic"
                ;;
index 1299442086e7b68d543c717637f9d25ddaa3a174..73fc9ca4995003d59d5ecf97b4e2abdbe74aeb2b 100644 (file)
@@ -19,6 +19,7 @@ CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
+CONFIG_AR71XX_MACH_WRT400N=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
index cdaa05dd0d4f400b32b9fce2807d4af76c2af2f3..a87927120608a334233c694206bf6b0c4c702728 100644 (file)
@@ -18,6 +18,7 @@ CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
+CONFIG_AR71XX_MACH_WRT400N=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
index 355a294e2b13ac47476798872f93d8b5f80d4041..de68695308fbf38d27c7591f3f3a93e5452ba86f 100644 (file)
@@ -31,6 +31,10 @@ config AR71XX_MACH_WP543
        select MYLOADER
        default y
 
        select MYLOADER
        default y
 
+config AR71XX_MACH_WRT400N
+       bool "Linksys WRT400N board support"
+       default y
+
 config AR71XX_MACH_RB_4XX
        bool "MikroTik RouterBOARD 4xx series support"
        default y
 config AR71XX_MACH_RB_4XX
        bool "MikroTik RouterBOARD 4xx series support"
        default y
index 64030540ec5210b599c9596dfc48ab7148ad8448..39510988c1960b084c464094e3ef59a54a93e1d9 100644 (file)
@@ -23,3 +23,4 @@ obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)  += mach-tl-wr941nd.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
+obj-$(CONFIG_AR71XX_MACH_WRT400N)      += mach-wrt400n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wrt400n.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wrt400n.c
new file mode 100644 (file)
index 0000000..90d9dd1
--- /dev/null
@@ -0,0 +1,162 @@
+/*
+ *  Linksys WRT400N board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2009 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "devices.h"
+
+#define WRT400N_GPIO_LED_ORANGE        5
+#define WRT400N_GPIO_LED_GREEN 4
+#define WRT400N_GPIO_LED_POWER 1
+#define WRT400N_GPIO_LED_WLAN  0
+
+#define WRT400N_GPIO_BTN_RESET 8
+#define WRT400N_GPIO_BTN_WLSEC 3
+
+#define WRT400N_BUTTONS_POLL_INTERVAL  20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wrt400n_partitions[] = {
+       {
+               .name           = "uboot",
+               .offset         = 0,
+               .size           = 0x030000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "env",
+               .offset         = 0x030000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "linux",
+               .offset         = 0x040000,
+               .size           = 0x140000,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x180000,
+               .size           = 0x630000,
+       } , {
+               .name           = "nvram",
+               .offset         = 0x7b0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "factory",
+               .offset         = 0x7c0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "language",
+               .offset         = 0x7d0000,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "caldata",
+               .offset         = 0x7f0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data wrt400n_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = wrt400n_partitions,
+        .nr_parts       = ARRAY_SIZE(wrt400n_partitions),
+#endif
+};
+
+static struct spi_board_info wrt400n_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+               .platform_data  = &wrt400n_flash_data,
+       }
+};
+
+static struct gpio_led wrt400n_leds_gpio[] __initdata = {
+       {
+               .name           = "wrt400n:green:status",
+               .gpio           = WRT400N_GPIO_LED_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "wrt400n:amber:aoss",
+               .gpio           = WRT400N_GPIO_LED_ORANGE,
+               .active_low     = 1,
+       }, {
+               .name           = "wrt400n:green:wlan",
+               .gpio           = WRT400N_GPIO_LED_WLAN,
+               .active_low     = 1,
+       }, {
+               .name           = "wrt400n:green:power",
+               .gpio           = WRT400N_GPIO_LED_POWER,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button wrt400n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 5,
+               .gpio           = WRT400N_GPIO_BTN_RESET,
+               .active_low     = 1,
+       } , {
+               .desc           = "wlsec",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .threshold      = 5,
+               .gpio           = WRT400N_GPIO_BTN_WLSEC,
+               .active_low     = 1,
+       }
+};
+
+static void __init wrt400n_setup(void)
+{
+       ar71xx_add_device_mdio(0x0);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth0_data.phy_mask = 0xf;
+       ar71xx_eth0_data.speed = SPEED_100;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+       ar71xx_eth0_data.has_ar8216 = 1;
+
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_spi(NULL, wrt400n_spi_info,
+                             ARRAY_SIZE(wrt400n_spi_info));
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(wrt400n_leds_gpio),
+                                       wrt400n_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, WRT400N_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(wrt400n_gpio_buttons),
+                                       wrt400n_gpio_buttons);
+
+       /* TODO: PCI support */
+}
+
+MIPS_MACHINE(AR71XX_MACH_WRT400N, "Linksys WRT400N", wrt400n_setup);
index 810b4747f143800b2978d37060c9b0e4b5428e51..aea7a245a4d9101cb0eb6b7c58d8999008858fa7 100644 (file)
@@ -77,6 +77,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "WNR2000",
                .mach_type      = AR71XX_MACH_WNR2000,
        }, {
                .name           = "WNR2000",
                .mach_type      = AR71XX_MACH_WNR2000,
+       }, {
+               .name           = "WRT400N",
+               .mach_type      = AR71XX_MACH_WRT400N,
        }, {
                .name           = "PB42",
                .mach_type      = AR71XX_MACH_PB42,
        }, {
                .name           = "PB42",
                .mach_type      = AR71XX_MACH_PB42,
index 52531ce0fbfb3a62c7577d338d947631a71f5511..90a3da37e458bb73a414a6f6bc978da03d86f30f 100644 (file)
@@ -130,6 +130,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_TL_WR941ND 16      /* TP-LINK TL-WR941ND */
 #define AR71XX_MACH_UBNT_RSPRO 17      /* Ubiquiti RouterStation Pro */
 #define AR71XX_MACH_AP81       18      /* Atheros AP81 */
 #define AR71XX_MACH_TL_WR941ND 16      /* TP-LINK TL-WR941ND */
 #define AR71XX_MACH_UBNT_RSPRO 17      /* Ubiquiti RouterStation Pro */
 #define AR71XX_MACH_AP81       18      /* Atheros AP81 */
+#define AR71XX_MACH_WRT400N    19      /* Linksys WRT400N */
 
 /*
  * PLL block
 
 /*
  * PLL block