Add faifa, configures and queries HomePlug 1.0/AV devices
authorFlorian Fainelli <florian@openwrt.org>
Mon, 5 Jan 2009 09:53:38 +0000 (09:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 5 Jan 2009 09:53:38 +0000 (09:53 +0000)
SVN-Revision: 13871

net/faifa/Makefile [new file with mode: 0644]

diff --git a/net/faifa/Makefile b/net/faifa/Makefile
new file mode 100644 (file)
index 0000000..e4382af
--- /dev/null
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=faifa
+PKG_REV:=11
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://svn.open-plc.org/trunk/
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/faifa
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread +libopenssl +libpcap
+  TITLE:=configure HomePlug 1.0/AV PLC devices
+  URL:=http://open-plc.org
+endef
+
+define Package/faifa/description
+  Faifa can configure any Intellon-based Power Line Communication
+  device using Intellon INT5000 and INT6000 series chips
+  (6000 and 6300 chips). It supports all Intellon-specific management
+  and control frames as well as standard management frames.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DSVN_REV=$(PKG_REV) -Iinclude/ -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               faifa
+endef
+
+define Package/faifa/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/faifa $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,faifa))