change SECTION and CATEGORY to put packages in the right place, change PKG_BUILDDEPs...
authorNicolas Thill <nico@openwrt.org>
Wed, 26 Jul 2006 01:26:21 +0000 (01:26 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 26 Jul 2006 01:26:21 +0000 (01:26 +0000)
SVN-Revision: 4296

17 files changed:
libs/avahi/Makefile
libs/axtls/Makefile
libs/curl/Makefile
libs/cyrus-sasl/Makefile
libs/gnutls/Makefile
libs/gsm/Makefile
libs/howl/Makefile
libs/id3lib/Makefile
libs/libelf/Makefile
libs/mysql/Makefile
libs/openldap/Makefile
libs/postgresql/Makefile
libs/radiusclient-ng/Makefile
libs/sqlite2/Makefile
libs/sqlite3/Makefile
net/kismet/Makefile
net/openssh/Makefile

index 8e9386a85a872acca79ebbdb1c98ee3481ccb2fd..da02db83f8ab845427b8fb63d8062d7d0a76f15f 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=cfb9e05c138dff4c430a35eee6229e8a
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=expat libdaemon libgdbm
+PKG_BUILDDEP:=libexpat libdaemon libgdbm
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,9 +41,9 @@ define Package/libavahi
 endef
 
 define Package/avahi-daemon
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libavahi
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libavahi
   TITLE:=An mDNS/DNS-SD implementation (daemon)
   DESCRIPTION:=An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (daemon).\\\
     Avahi is a system which facilitates service discovery on a local network -- \\\
@@ -64,9 +64,9 @@ define Package/avahi-daemon/conffiles
 endef
 
 define Package/avahi-dnsconfd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libavahi
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libavahi
   TITLE:=An Unicast DNS server from mDNS/DNS-SD configuration daemon
   DESCRIPTION:=An Unicast DNS server from mDNS/DNS-SD configuration daemon.\\\
     Avahi is a system which facilitates service discovery on a local network -- \\\
index 8a567047c5b771ac8ae56fb21f2fcdcf8c630665..c74094281c0e9c0b6c39f6028adaff7c556a494c 100644 (file)
@@ -29,9 +29,9 @@ define Package/libaxtls
 endef
 
 define Package/awhttpd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libaxtls
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libaxtls
   TITLE:=Anti-Web webserver
   DESCRIPTION:=Anti-Web webserver.
   URL:=http://www.axtls.co.nr/
index 37932d658d20e78f06be17a275d2d9f76f94a599..3510c98b92ec38b73e9020c135cf7abfc7c5b085 100644 (file)
@@ -38,9 +38,9 @@ define Package/libcurl
 endef
 
 define Package/curl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libcurl
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libcurl
   TITLE:=A client-side URL transfer library
   DESCRIPTION:=A client-side URL transfer library.
   URL:=http://curl.haxx.se/
index 5efcab8b30d3915b9fe7e781c61aab2ed015602d..fa1240d7702054909a9b38ef5981446dd303ca12 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=268ead27f4ac39bcfe17d9e38e0f2977
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=openssl
+PKG_BUILDDEP:=libopenssl
 
 include $(INCLUDE_DIR)/package.mk
 
index 9d952b3edd3d63bad13de00c7096e15a438ef36c..bb0f960e96254f8774f0607261189b5cdb47b54a 100644 (file)
@@ -41,33 +41,33 @@ define Package/libgnutls
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
-define Package/gnutls-utils
+define Package/libgnutls-openssl
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=libgnutls
-  TITLE:=GNU TLS utilitis
-  DESCRIPTION:=The GNU TLS utilities.\\\
+  TITLE:=GNU TLS OpenSSL compatibility layer library
+  DESCRIPTION:=The GNU TLS OpenSSL compatibility layer library.\\\
     GnuTLS is a project that aims to develop a library which provides a \\\
     secure layer, over a reliable transport layer. Currently the GnuTLS \\\
     library implements the proposed standards by the IETF's TLS working \\\
     group.\\\
     \\\
-    This packages contains some GnuTLS utilities.
+    This packages contains the GnuTLS OpenSSL compatibility layer shared library.
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
-define Package/libgnutls-openssl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libgnutls
-  TITLE:=GNU TLS OpenSSL compatibility layer library
-  DESCRIPTION:=The GNU TLS OpenSSL compatibility layer library.\\\
+define Package/gnutls-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libgnutls
+  TITLE:=GNU TLS utilitis
+  DESCRIPTION:=The GNU TLS utilities.\\\
     GnuTLS is a project that aims to develop a library which provides a \\\
     secure layer, over a reliable transport layer. Currently the GnuTLS \\\
     library implements the proposed standards by the IETF's TLS working \\\
     group.\\\
     \\\
-    This packages contains the GnuTLS OpenSSL compatibility layer shared library.
+    This packages contains some GnuTLS utilities.
   URL:=http://www.gnu.org/software/gnutls/
 endef
 
index 9cdc19aa7990d0cc023ed732a82cc172641c3def..e1c6225f79d9e9ffd7b40954544f87bf15ffdcc0 100644 (file)
@@ -35,9 +35,9 @@ define Package/libgsm
 endef
 
 define Package/gsm-utils
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libgsm
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libgsm
   TITLE:=GSM transcoding utilities
   DESCRIPTION:=A GSM 06.10 full-rate speech transcoding implementation (utilities).\\\
     An implementation of the European GSM 06.10 provisional standard \\\
index 88f1dbde493930e333ea704bb14e8ad64194b37f..2fea756bcfcfef61a4d0431713292c9e4b016b74 100644 (file)
@@ -34,9 +34,9 @@ define Package/libhowl
 endef
 
 define Package/howl-utils
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libhowl
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libhowl
   TITLE:=A Zeroconf networking implementation (utilities)
   DESCRIPTION:=A Zeroconf networking implementation (utilities).\\\
     A cross-platform implementation of Zeroconf networking.\\\
@@ -46,9 +46,9 @@ define Package/howl-utils
 endef
 
 define Package/autoipd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libhowl
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libhowl
   TITLE:=An IPv4 Link-Local address self-assigner daemon
   DESCRIPTION:=An IPv4 Link-Local address self-assigner daemon.\\\
     A cross-platform implementation of Zeroconf networking.\\\
@@ -58,9 +58,9 @@ define Package/autoipd
 endef
 
 define Package/mdnsresponder
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libhowl
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libhowl
   TITLE:=An mDNS (Multicast DNS) service responder daemon
   DESCRIPTION:=An mDNS (Multicast DNS) service responder daemon.\\\
     A cross-platform implementation of Zeroconf networking.\\\
@@ -74,9 +74,9 @@ define Package/mdnsresponder/conffiles
 endef
 
 define Package/nifd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libhowl
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libhowl
   TITLE:=A network interface monitor daemon
   DESCRIPTION:=A network interface monitor daemon.\\\
     A cross-platform implementation of Zeroconf networking.\\\
index feada69bdc2044243dca32d588354c9914dd4634..8faa62e0a7b62ae7e98cf5f2d8b80cf29a2d050e 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/id3lib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib +uclibc++
+  DEPENDS:=+zlib +uclibcxx
   TITLE:=An ID3v1/ID3v2 tag manipulation library
   DESCRIPTION:=An ID3v1/ID3v2 tag manipulation library.\\\
   URL:=http://www.id3lib.org/
index ac481b7d322314d52249054a23ed726870cecf3e..ba16def6a5e36a0c9caa87caf3c26ea640f1649d 100644 (file)
@@ -31,7 +31,7 @@ define Package/libelf
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
index fa9a27786ab738dff87d62eeb328747d304b66e0..4c7ddec195b2432f1814e0349cf01509767995a4 100644 (file)
@@ -23,7 +23,7 @@ PKG_MD5SUM:=f18153b0239aaa03fc5a751f2d82cb71
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=ncurses readline
+PKG_BUILDDEP:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
index 6a956c7c7db3cc29909fe10abcecac1d63d3bff3..4d5a1bacfb56eb746a4265c3f1884b11ab028131 100644 (file)
@@ -59,9 +59,9 @@ define Package/libopenldap/conffiles
 endef
 
 define Package/openldap-utils
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libopenldap
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenldap
   TITLE:=LDAP client utilities
   DESCRIPTION:=LDAP (Lightweight Directory Access Protocol) client utilities.\\\
     OpenLDAP Software is an open source implementation of the \\\
index 78cc54256941ddc072d6f754265c4eb293a07688..9ee1d5253db3cb2266a048ae693e262358fb0014 100644 (file)
@@ -36,9 +36,9 @@ define Package/libpq
 endef
 
 define Package/pgsql-cli
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libpq
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libpq
   TITLE:=Command Line Interface (CLI) to PostgreSQL databases
   DESCRIPTION:=Command Line Interface (CLI) to PostgreSQL databases.
   URL:=http://www.postgresql.org/
index 4afdd3f9bcea24f2cce020e5efa50d60213698dd..57d4b8becf8b88a160bd6feec56bd5bf8e2dfde6 100644 (file)
@@ -42,11 +42,10 @@ define Package/libradiusclient-ng/conffiles
 /etc/radiusclient-ng/servers
 endef
 
-
 define Package/radiusclient-ng
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libradiusclient-ng
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libradiusclient-ng
   TITLE:=A RADIUS client
   DESCRIPTION:=A RADIUS client.\\\
     Purpose of this project is to build a portable, easy-to-use and standard \\\
index a8d8fce3e0ceb218c7b494c68f24b6442e188b26..1e5179f6089f20701d01746435198f19280c2cb1 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=838dbac20b56d2c4292e98848505a05b
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=ncurses readline
+PKG_BUILDDEP:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,9 +36,9 @@ define Package/libsqlite2
 endef
 
 define Package/sqlite2-cli
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libsqlite2 +libncurses +libreadline
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libsqlite2 +libncurses +libreadline
   TITLE:=Command line interface for SQLite
   DESCRIPTION:=Command line interface for SQLite.\\\
     SQLite is a small C library that implements a self-contained, embeddable, \\\
index a60b35e381c2336d93de02263c7e0c74195d56d7..61df399015c2d62dc2439cb95dabecf6bbc5f1e4 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=eb5d9d7e7853b3af78e767d709b7fced
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=ncurses readline
+PKG_BUILDDEP:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,9 +36,9 @@ define Package/libsqlite3
 endef
 
 define Package/sqlite3-cli
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=libsqlite3 +libncurses +libreadline
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libsqlite3 +libncurses +libreadline
   TITLE:=Command line interface for SQLite
   DESCRIPTION:=Command line interface for SQLite.\\\
     SQLite is a small C library that implements a self-contained, embeddable, \\\
index 72bc49917adeb65779f2d68cd142742bb5130f0f..2484850ccaf15aa2e78d1b5fae36941eab948828 100644 (file)
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://www.kismetwireless.net/code
 PKG_MD5SUM:=8ec2de513f2911df1b7edfcba5ad1c26
 PKG_CAT:=zcat
 
-PKG_BUILDDEP:=libpcap ncurses uclibc++
+PKG_BUILDDEP:=libpcap libncurses uclibcxx
 
 include $(INCLUDE_DIR)/package.mk
 
index 4e193342562bcf9205f18fc8e464dc79388c4fab..3d1539c566910ba5659387093fb435a8392c27dc 100644 (file)
@@ -22,7 +22,7 @@ PKG_MD5SUM:=df899194a340c933944b193477c628fa
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_BUILDDEP:=openssl
+PKG_BUILDDEP:=libopenssl
 
 include $(INCLUDE_DIR)/package.mk