port freetype to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Wed, 26 Jul 2006 00:32:07 +0000 (00:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 26 Jul 2006 00:32:07 +0000 (00:32 +0000)
SVN-Revision: 4289

libs/freetype/Makefile [new file with mode: 0644]

diff --git a/libs/freetype/Makefile b/libs/freetype/Makefile
new file mode 100644 (file)
index 0000000..5ac0e39
--- /dev/null
@@ -0,0 +1,102 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libfreetype
+PKG_VERSION:=2.1.9
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/freetype-$(PKG_VERSION)
+PKG_SOURCE:=freetype-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/freetype
+PKG_MD5SUM:=ec1b903e4be5f073caa72458ea58c29c
+PKG_CAT:=bzcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libfreetype
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+zlib
+  TITLE:=A free, high-quality and portable font engine
+  DESCRIPTION:=A free, high-quality and portable font engine.\\\
+    The FreeType project is a team of volunteers who develop free, \\\
+    portable and high-quality software solutions for digital typography.\\\
+    They specifically target embedded systems and focus on bringing small, \\\
+    efficient and ubiquitous products.
+  URL:=http://www.freetype.org/
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               $(TARGET_CONFIGURE_OPTS) \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --sbindir=/usr/sbin \
+                       --libexecdir=/usr/lib \
+                       --sysconfdir=/etc \
+                       --datadir=/usr/share \
+                       --localstatedir=/var \
+                       --mandir=/usr/man \
+                       --infodir=/usr/info \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+                       --enable-shared=yes \
+                       --enable-static=yes \
+                       --disable-rpath \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/libfreetype/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(STAGING_DIR)/usr/bin/
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/freetype-config \
+               $(STAGING_DIR)/usr/include/freetype2 \
+               $(STAGING_DIR)/usr/include/ft2build.h \
+               $(STAGING_DIR)/usr/lib/libfreetype.{a,so*} \
+               $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
+endef
+
+$(eval $(call BuildPackage,libfreetype))