[package] ncurses: build C++ bindings only our toolchain supports C++
authorFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2012 13:05:15 +0000 (13:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2012 13:05:15 +0000 (13:05 +0000)
SVN-Revision: 33909

package/libs/ncurses/Makefile

index 0b88ab6feb54c92d3aea5f8778d56076560c7a6c..465b60cae1467191f2bbc5cf5c1848053bb2af2c 100644 (file)
@@ -67,6 +67,11 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+ifneq ($(INSTALL_LIBSTDCPP),y)
+CONFIGURE_ARGS += \
+       --without-cxx-binding
+endif
+
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db