[packages] mini-snmpd: fix a segfault when passing an invalid oid to the -V option...
authorNicolas Thill <nico@openwrt.org>
Tue, 28 Apr 2009 15:29:14 +0000 (15:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 28 Apr 2009 15:29:14 +0000 (15:29 +0000)
SVN-Revision: 15469

net/mini_snmpd/Makefile
net/mini_snmpd/patches/103-mib_encode_snmp_element_oid_fix.patch [new file with mode: 0644]

index 6433a1f0c673e3c4f780815370e8b08a28a758b5..da0cb16a1ac6a01f5792a3baf3eaab3f12df221b 100644 (file)
@@ -30,7 +30,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               OFLAGS="$(TARGET_CFLAGS)" \
+               OFLAGS="$(TARGET_CFLAGS) -DSYSLOG" \
                STRIP="/bin/true" \
                INSTALL_ROOT="$(PKG_INSTALL_DIR)" \
                mini_snmpd install
diff --git a/net/mini_snmpd/patches/103-mib_encode_snmp_element_oid_fix.patch b/net/mini_snmpd/patches/103-mib_encode_snmp_element_oid_fix.patch
new file mode 100644 (file)
index 0000000..a46ace2
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/mib.c
++++ b/mib.c
+@@ -120,6 +120,9 @@ static int encode_snmp_element_oid(value
+       int length;
+       int i;
++      if (oid_value == NULL) {
++              return -1;
++      }
+       buffer = value->data.buffer;
+       length = 1;
+       for (i = 2; i < oid_value->subid_list_length; i++) {
+@@ -293,6 +296,8 @@ static int mib_build_entry(const oid_t *
+                       value->data.encoded_length = 0;
+                       value->data.buffer = malloc(value->data.max_length);
+                       if (encode_snmp_element_oid(value, oid_aton((const char *)default_value)) == -1) {
++                              lprintf(LOG_ERR, "could not create MIB entry '%s.%d.%d': invalid oid '%s'\n",
++                                      oid_ntoa(prefix), column, row, (char *)default_value);
+                               return -1;
+                       }
+                       break;