backport [2184] (openssh sftp-server) to trunk
authorNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 13:54:29 +0000 (13:54 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 13:54:29 +0000 (13:54 +0000)
SVN-Revision: 2185

openwrt/package/openssh/Makefile
openwrt/package/openssh/ipkg/openssh-client-utils.control
openwrt/package/openssh/ipkg/openssh-server.control
openwrt/package/openssh/ipkg/openssh-sftp-client.control
openwrt/package/openssh/ipkg/openssh-sftp-server.control

index 2d4a554a79535501363317620becabcb3c81cd72..742a8086fcd74f3b628437fa23a1bf8ec8e410f8 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=4.0p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=7b36f28fc16e1b7f4ba3c1dca191ac92
 
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -35,39 +35,39 @@ $(PKG_BUILD_DIR)/.configured:
                LD="$(TARGET_CC)" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc/ssh \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --disable-static \
-                 --disable-debug \
-                 --disable-strip \
-                 --disable-etc-default-login \
-                 --disable-lastlog \
-                 --disable-utmp \
-                 --disable-utmpx \
-                 --disable-wtmp \
-                 --disable-wtmpx \
-                 --without-bsd-auth \
-                 --without-kerberos5 \
-                 --without-pam \
-                 --without-x \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc/ssh \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --disable-debug \
+                       --disable-strip \
+                       --disable-etc-default-login \
+                       --disable-lastlog \
+                       --disable-utmp \
+                       --disable-utmpx \
+                       --disable-wtmp \
+                       --disable-wtmpx \
+                       --without-bsd-auth \
+                       --without-kerberos5 \
+                       --without-pam \
+                       --without-x \
        );
        touch $@
 
@@ -117,6 +117,8 @@ $(IPKG_OPENSSH_SFTP_CLIENT):
 $(IPKG_OPENSSH_SFTP_SERVER):
        install -m0755 -d $(IDIR_OPENSSH_SFTP_SERVER)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/sftp-server $(IDIR_OPENSSH_SFTP_SERVER)/usr/lib/
+       install -m0755 -d $(IDIR_OPENSSH_SFTP_SERVER)/usr/libexec
+       ln -sf ../lib/sftp-server $(IDIR_OPENSSH_SFTP_SERVER)/usr/libexec/sftp-server
        $(RSTRIP) $(IDIR_OPENSSH_SFTP_SERVER)
        $(IPKG_BUILD) $(IDIR_OPENSSH_SFTP_SERVER) $(PACKAGE_DIR)
 
index 981e2a2c7b095b6aad993d9294e507c72798c5eb..280e6bfcc7a958b7ae1b25930c7fa538c9baed2e 100644 (file)
@@ -1,7 +1,7 @@
 Package: openssh-client-utils
 Priority: optional
 Section: net
-Maintainer: bugs@openwrt.org
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: buildroot internal
 Depends: zlib, libopenssl
 Description: OpenSSH client utilities
index 8247c3f110c1ab695d8c38c80b5cdad326c83efc..22ce485ee46620cda87175ccccd54a9112cd14ea 100644 (file)
@@ -1,7 +1,7 @@
 Package: openssh-server
 Priority: optional
 Section: net
-Maintainer: bugs@openwrt.org
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: buildroot internal
 Depends: zlib, libopenssl
 Description: OpenSSH server
index 0edad501bd94e82ee35bf3b085aeae76d4d38a74..2accca8d138e1945d70c0ec580b961ee81575c0b 100644 (file)
@@ -1,7 +1,7 @@
 Package: openssh-sftp-client
 Priority: optional
 Section: net
-Maintainer: bugs@openwrt.org
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: buildroot internal
 Depends: zlib, libopenssl
 Description: OpenSSH SFTP client
index fba5d6a16903bfa0c81b42f4096d84008abdcdee..1e17432de151b021ac66f076ec3f37bc2ab454bf 100644 (file)
@@ -1,7 +1,7 @@
 Package: openssh-sftp-server
 Priority: optional
 Section: net
-Maintainer: bugs@openwrt.org
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: buildroot internal
 Depends: zlib, libopenssl
 Description: OpenSSH SFTP server