Install taglib-config to $(STAGING_DIR)/host/bin rather then
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 15:33:00 +0000 (15:33 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 15:33:00 +0000 (15:33 +0000)
$(STAGING_DIR)/usr/bin.

SVN-Revision: 12902

libs/taglib/Makefile

index f62376be29413a8592bd2c55fb2e082f57619b9f..0585651c4339cf264ea87120951d6f539f0ea0dc 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,6 +18,8 @@ PKG_MD5SUM:=dcd50ddb2544faeae77f194804559404
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/taglib
   SECTION:=libs
   CATEGORY:=Libraries
@@ -39,19 +41,23 @@ CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS" \
        LIBS="-nodefaultlibs -lz -luClibc++" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/taglib-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/include/taglib
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/taglib/* $(1)/usr/include/taglib/
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/taglib-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/taglib-config
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libtag.{la,so*} \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include/taglib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/taglib/* \
+               $(1)/usr/include/taglib/
 endef
 
 define Package/taglib/install