[packages_10.03.2] unfs3: merge r29068, r29199
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:31:36 +0000 (16:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:31:36 +0000 (16:31 +0000)
SVN-Revision: 30275

net/unfs3/Makefile
net/unfs3/files/unfs3.init

index a0ab326fa3977341cd2ca57548cb8215228a4f57..3764aae3a8f9519dd6053c946b1d649d8da99fb5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unfs3
 PKG_VERSION:=0.9.22
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -47,4 +47,8 @@ define Package/unfs3/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unfsd $(1)/usr/sbin
 endef
 
+define Package/unfs3/conffiles
+/etc/exports
+endef
+
 $(eval $(call BuildPackage,unfs3))
index 204c4fdb42be3c652312451b7d1b586cc612ba99..4a5965ab97b128ffd7c91d36bee297db156136e5 100644 (file)
@@ -1,17 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
 start() {
-       /usr/sbin/unfsd
+       service_start /usr/sbin/unfsd
 }
 
 stop() {
-       killall unfsd
-}
-
-restart() {
-       stop
-       sleep 1
-       start
+       service_stop /usr/sbin/unfsd
 }