[package] soloscli utility for Solos ADSL2+ modems
authorFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 13:46:32 +0000 (13:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 13:46:32 +0000 (13:46 +0000)
Utility for interrogating Traverse Technologies' Solos ADSL2+ modems

Signed-off-by: Nathan Williams <nathan@traverse.com.au>
SVN-Revision: 23619

package/soloscli/Makefile [new file with mode: 0644]
package/soloscli/patches/000-Makefile.patch [new file with mode: 0644]
package/soloscli/patches/001-newline.patch [new file with mode: 0644]

diff --git a/package/soloscli/Makefile b/package/soloscli/Makefile
new file mode 100644 (file)
index 0000000..611dbcc
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=soloscli
+PKG_VERSION:=0.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/openadsl
+PKG_MD5SUM:=ab3f3fa654ef7c3a402980eca094e690
+
+PKG_INSTALL:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/soloscli
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Configuration utility for Solos ADSL2+ modems
+  DEPENDS:=+kmod-solos-pci
+  URL:=http://sourceforge.net/projects/openadsl
+endef
+
+define Package/soloscli/description
+  This package contains the soloscli utility
+  for interrogating Traverse Technologies' Solos ADSL2+ modems.
+endef
+
+define Package/soloscli/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/soloscli/soloscli $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,soloscli))
diff --git a/package/soloscli/patches/000-Makefile.patch b/package/soloscli/patches/000-Makefile.patch
new file mode 100644 (file)
index 0000000..914d6d8
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/Makefile 2010-06-14 14:17:11.000000000 +1000
++++ b/Makefile 2010-06-14 14:17:54.000000000 +1000
+@@ -13,6 +13,11 @@
+ KDIR  ?= /lib/modules/$(shell uname -r)/build
+ PWD   := $(shell pwd)
++soloscli/soloscli:
++      $(MAKE) -C soloscli
++
++install:
++
+ default:
+       $(MAKE) -C $(KDIR) M=$(PWD) modules
+@@ -20,5 +25,6 @@
+       rm -f *.o *.ko *.mod.c .*.cmd
+       rm -rf .tmp_versions
+       rm -f Module.symvers
++      $(MAKE) -C soloscli clean
+ endif
diff --git a/package/soloscli/patches/001-newline.patch b/package/soloscli/patches/001-newline.patch
new file mode 100644 (file)
index 0000000..69cd5b2
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/soloscli/soloscli.c
++++ b/soloscli/soloscli.c
+@@ -238,7 +238,7 @@
+       }
+       if (strcmp(buf,pid) == 0) {
+ /*            printf("Sequence matches.\n"); */
+-              printf("%s",bufp);
++              printf("%s\n",bufp);
+       } else {
+               printf("Sequence incorrect.\n");
+               buf[i] = '\n';