this patch updates sudo to the latest stable version: 1.7.2p3
authorTravis Kemen <thepeople@openwrt.org>
Thu, 18 Feb 2010 00:33:06 +0000 (00:33 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 18 Feb 2010 00:33:06 +0000 (00:33 +0000)
-Raphael

SVN-Revision: 19695

admin/sudo/Makefile

index ba72e0ee4192b910a742837ae323c5bdc7452ca4..d9cc4c8a3f5cbdb2510dc1d23b064b96e701752b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,43 +7,43 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sudo
-PKG_VERSION:=1.7.2p2
+PKG_VERSION:=1.7.2p3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sudo.ws/sudo/dist/
-PKG_MD5SUM:=2a19cf1ab4afc94fe19d0d0899d4cd45
+PKG_MD5SUM:=b4bb9a0ae896958b71e48ef91967cdcb
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sudo
-  SECTION:= admin
+  SECTION:=admin
   CATEGORY:=Administration
-  TITLE:=delegate authority to run commands
+  TITLE:=Delegate authority to run commands
   URL:=http://www.sudo.ws/
 endef
 
 define Package/sudo/description
-  Sudo (su "do") allows a system administrator to delegate authority to give
-  certain users (or groups of users) the ability to run some (or all) commands
-  as root or another user while providing an audit trail of the commands and
-  their arguments.
+Sudo (su "do") allows a system administrator to delegate authority to give
+certain users (or groups of users) the ability to run some (or all) commands as
+root or another user while providing an audit trail of the commands and their
+arguments.
+endef
+
+define Package/sudo/conffiles
+/etc/sudoers
 endef
 
 CONFIGURE_ARGS+= \
        --without-pam \
        --disable-pam-session \
-       --with-editor=/bin/vi \
+       --with-editor=/bin/vi
 
 CONFIGURE_VARS+= \
        sudo_cv_uid_t_len=10 \
-       sudo_cv_func_unsetenv_void=no \
-
-define Package/sudo/conffiles
-/etc/sudoers
-endef
+       sudo_cv_func_unsetenv_void=no
 
 define Package/sudo/install
        $(INSTALL_DIR) $(1)/usr/bin