Add init files and iptables rule for ptunnel to work (#2863)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 21 Dec 2007 09:34:01 +0000 (09:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 21 Dec 2007 09:34:01 +0000 (09:34 +0000)
Signed-off-by: michu-at-neophob-com
SVN-Revision: 9818

net/ptunnel/Makefile
net/ptunnel/files/ptunnel.init [new file with mode: 0644]

index 39dc30a3f36a112e705de86bca581df49da28604..d4aada558c58ba412544c772374e8c91aa73973f 100644 (file)
@@ -47,6 +47,8 @@ endef
 define Package/ptunnel/install 
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ptunnel $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ptunnel.init $(1)/etc/init.d/ptunnel
 endef
 
 $(eval $(call BuildPackage,ptunnel))
diff --git a/net/ptunnel/files/ptunnel.init b/net/ptunnel/files/ptunnel.init
new file mode 100644 (file)
index 0000000..da3b143
--- /dev/null
@@ -0,0 +1,14 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+START=70
+STOP=70
+
+start() {
+        iptables -I OUTPUT 1 -p icmp -j ACCEPT
+       ptunnel -v 1 -c br-lan
+}
+               
+stop() {
+        killall ptunnel
+}
+                       
\ No newline at end of file