Add libnmeap (#1999)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2007 13:51:45 +0000 (13:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2007 13:51:45 +0000 (13:51 +0000)
SVN-Revision: 8155

libs/nmeap/Makefile [new file with mode: 0644]
libs/nmeap/patches/100-no_test.patch [new file with mode: 0644]

diff --git a/libs/nmeap/Makefile b/libs/nmeap/Makefile
new file mode 100644 (file)
index 0000000..d0629e1
--- /dev/null
@@ -0,0 +1,44 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nmeap
+PKG_VERSION:=0.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/nmeap
+PKG_MD5SUM:=cbcc9fdf5176f9d6c9e48f27db443c4f
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnmeap
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=extensible NMEA-0183 parser written in standard C
+  DESCRIPTION:=The NMEAP parser is intended for use in applications that need to input NMEA-0183 \\\
+       data from a GPS (typically over a serial port). NMEAP is a linkable library written in portable \\\
+       standard C and is suitable for both desktop and embedded applications. \\\
+       It is licensed under the BSD open source license.
+  URL:=http://www.dmh2000.com/nmea/nmeap.shtml
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/inc/nmeap{,_def}.h $(STAGING_DIR)/usr/include/
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnmeap.a $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -f $(STAGING_DIR)/usr/include/nmeap{,_def}.h \
+               $(STAGING_DIR)/usr/lib/libnmeap.a
+endef
+
+$(eval $(call BuildPackage,libnmeap))
diff --git a/libs/nmeap/patches/100-no_test.patch b/libs/nmeap/patches/100-no_test.patch
new file mode 100644 (file)
index 0000000..891e2a8
--- /dev/null
@@ -0,0 +1,21 @@
+--- nmeap-0.3/Makefile         2005-05-06 19:57:39.000000000 +0200
++++ nmeap-0.3.new/Makefile     2007-07-25 15:26:47.000000000 +0200
+@@ -5,18 +5,15 @@
+ # directories\r
+ BASE :=$(shell pwd)\r
+ export SRC=$(BASE)/src\r
+-export TST=$(BASE)/tst\r
+ export INC=$(BASE)/inc\r
+ export LIB=$(BASE)/lib\r
\r
+ all :\r
+       cd $(SRC) && $(MAKE) all\r
+-      cd $(TST) && $(MAKE) all\r
+       \r
\r
+ clean :\r
+       cd $(SRC) && $(MAKE) clean\r
+-      cd $(TST) && $(MAKE) clean\r
+       \r
+ doc  :\r
+       doxygen\r