Added support for /etc/default/fstab - a means of automatically mounting devices...
authorRod Whitby <rod@whitby.id.au>
Fri, 21 Sep 2007 13:20:50 +0000 (13:20 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 21 Sep 2007 13:20:50 +0000 (13:20 +0000)
SVN-Revision: 8916

package/base-files/Makefile
package/base-files/files/etc/config/fstab [new file with mode: 0644]
package/base-files/files/etc/init.d/fstab [new file with mode: 0755]

index c639df83865d362d75e125777e7d5acc786fa82b..0cf96e2c8641da317118aafaa5ea412123176286 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
diff --git a/package/base-files/files/etc/config/fstab b/package/base-files/files/etc/config/fstab
new file mode 100644 (file)
index 0000000..28bb705
--- /dev/null
@@ -0,0 +1,6 @@
+config mount
+       option target   /home
+       option device   /dev/sda1
+       option fstype   ext3
+       option options  rw,sync
+       option enabled  0
diff --git a/package/base-files/files/etc/init.d/fstab b/package/base-files/files/etc/init.d/fstab
new file mode 100755 (executable)
index 0000000..2a63a5b
--- /dev/null
@@ -0,0 +1,42 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+
+START=20
+
+do_mount() {
+       local cfg="$1"
+       config_get fstype "$cfg" fstype
+       fstype="${fstype:-auto}"
+       config_get options "$cfg" options
+       options="${options:-rw}"
+       config_get device "$cfg" device
+       [ -n "device" ] || return 0
+       config_get target "$cfg" target
+       [ -n "target" ] || return 0
+       mkdir -p $target
+       config_get_bool enabled "$cfg" "enabled" '1'
+       [ "$enabled" -gt 0 ] && {
+         /bin/mount -t $fstype -o $options $device $target 
+       }
+}
+
+do_unmount() {
+       local cfg="$1"
+       config_get target "$cfg" target
+       [ -n "target" ] || return 0
+       config_get_bool enabled "$cfg" "enabled" '1'
+       [ "$enabled" -gt 0 ] && {
+         /bin/umount $target 
+       }
+}
+       
+start() {
+       config_load fstab
+       config_foreach do_mount mount
+}
+
+stop() {
+       config_load fstab
+       config_foreach do_unmount mount
+}
+