[PATCH] ipcalc.sh CIDR notation
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 May 2011 09:50:06 +0000 (09:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 May 2011 09:50:06 +0000 (09:50 +0000)
Hi,

the attached patch makes ipcalc.sh accept IP/Netmask combinations in
CIDR notation. Before you could only do:

# sh ipcalc.sh 192.168.0.0 255.255.255.0 1 10
IP=192.168.0.0
NETMASK=255.255.255.0
BROADCAST=192.168.0.255
NETWORK=192.168.0.0
PREFIX=24
START=192.168.0.1
END=192.168.0.11

with this patch you can also execute it with:

sh ipcalc.sh 192.168.0.0/24 1 10
IP=192.168.0.0
NETMASK=255.255.255.0
BROADCAST=192.168.0.255
NETWORK=192.168.0.0
PREFIX=24
START=192.168.0.1
END=192.168.0.11

The patch is based on #1260 [1], i just changed one line to calculate
the START end END ips right. I wonder why that never got included. If
there is no reason not to do i would like to ask you to commit that
patch, because its a functionality i (and probably others) miss quite often.

Btw, i also fixed 4 useless tabs, that might look a bit strange in the
patch.

Regards, Manuel

SVN-Revision: 26930

package/base-files/Makefile
package/base-files/files/bin/ipcalc.sh

index c10f4832707759180c91e1fcbc4573311863616d..3d179aed09e0068e14c8f15448e437c04727bed0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=69
+PKG_RELEASE:=70
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 9057e859289b8dd5f0ba66d2c2d50c842a9a7e76..d6ef168706cb75c8c3a2a7ded04a2508166528ce 100755 (executable)
@@ -23,15 +23,24 @@ function int2ip(ip,ret,x) {
 }
 
 BEGIN {
-       ipaddr=ip2int(ARGV[1])
-       netmask=ip2int(ARGV[2])
+       slpos=index(ARGV[1],"/")
+       if (slpos == 0) {
+               ipaddr=ip2int(ARGV[1])
+               netmask=ip2int(ARGV[2])
+       } else {
+               ipaddr=ip2int(substr(ARGV[1],0,slpos-1))
+               netmask=compl(2**(32-int(substr(ARGV[1],slpos+1)))-1)
+               ARGV[4]=ARGV[3]
+               ARGV[3]=ARGV[2]
+       }
+
        network=and(ipaddr,netmask)
        broadcast=or(network,compl(netmask))
-       
+
        start=or(network,and(ip2int(ARGV[3]),compl(netmask)))
        limit=network+1
        if (start<limit) start=limit
-       
+
        end=start+ARGV[4]
        limit=or(network,compl(netmask))-1
        if (end>limit) end=limit
@@ -41,10 +50,10 @@ BEGIN {
        print "BROADCAST="int2ip(broadcast)
        print "NETWORK="int2ip(network)
        print "PREFIX="32-bitcount(compl(netmask))
-       
+
        # range calculations:
        # ipcalc <ip> <netmask> <start> <num>
-       
+
        if (ARGC > 3) {
                print "START="int2ip(start)
                print "END="int2ip(end)