Add icmptx IP over ICMP tunneling program
authorFlorian Fainelli <florian@openwrt.org>
Sun, 21 Jan 2007 15:53:41 +0000 (15:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 21 Jan 2007 15:53:41 +0000 (15:53 +0000)
SVN-Revision: 6159

net/icmptx/Makefile [new file with mode: 0644]
net/icmptx/patches/01-cross_compile.patch [new file with mode: 0644]

diff --git a/net/icmptx/Makefile b/net/icmptx/Makefile
new file mode 100644 (file)
index 0000000..38c68cd
--- /dev/null
@@ -0,0 +1,43 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=icmptx
+PKG_VERSION:=0.01
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://thomer.com/icmptx/
+PKG_MD5SUM:=f83d1d7789a1b100abcc00d1a56ee95d
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/icmptx
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=allows you to pass IP packets via DNS queries
+  URL:=http://thomer.com/icmptx/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)"
+endef
+
+define Package/icmptx/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/icmptx $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,icmptx))
diff --git a/net/icmptx/patches/01-cross_compile.patch b/net/icmptx/patches/01-cross_compile.patch
new file mode 100644 (file)
index 0000000..e3b848b
--- /dev/null
@@ -0,0 +1,24 @@
+diff -urN icmptx-0.01/Makefile icmptx-0.01.new/Makefile
+--- icmptx-0.01/Makefile       2005-12-20 09:09:34.000000000 +0100
++++ icmptx-0.01.new/Makefile   2007-01-21 16:48:36.000000000 +0100
+@@ -3,16 +3,16 @@
+ all: icmptx
+ icmptx: it.o icmptx.o tun_dev.o
+-      gcc $(flags) -o icmptx icmptx.o it.o tun_dev.o
++      $(CC) -o icmptx icmptx.o it.o tun_dev.o
+ it.o: it.c
+-      gcc $(flags) -c it.c
++      $(CC) -c it.c
+ icmptx.o: icmptx.c
+-      gcc $(flags) -c icmptx.c
++      $(CC) -c icmptx.c
+ tun_dev.o: tun_dev.c
+-      gcc $(flags) -c tun_dev.c
++      $(CC) -c tun_dev.c
+ clean:
+       rm -f tun_dev.o it.o icmptx.o icmptx