brcm63xx: make use of the new BuildDTB command
authorJonas Gorski <jogo@openwrt.org>
Thu, 16 Jul 2015 11:13:47 +0000 (11:13 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 16 Jul 2015 11:13:47 +0000 (11:13 +0000)
Now that we have a BuildDTB command, make use of it instead of calling
dtc directly.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46390

target/linux/brcm63xx/image/Makefile

index 63cd90a17dde4ded8d0007b4877a8c647a883c52..98d145276cd7e3432b03858b014a004d2e39fdac 100755 (executable)
@@ -198,7 +198,7 @@ endef
 
 define Image/PrepareCFELzmaKernelDTB
        # compile the dts (the dtb will be later reused for the lzma loader)
-       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
+       $(call Image/BuildDTB,../dts/$(1).dts,$(DTS_DIR)/$(1).dtb)
        cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
        $(call Image/PrepareCFELzmaKernel,-$(1))
        rm -f $(KDIR)/vmlinux-$(1)