split fbsetbg into a seperate package and make X call it on startup, if it is preset
authorJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:32:16 +0000 (21:32 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:32:16 +0000 (21:32 +0000)
SVN-Revision: 9198

XOrg/app/fluxbox/Makefile
XOrg/meta/xorg-server-essentials/files/xinitrc

index 68fd0f74913783e863d6112d98a5bc45c0d829fd..eaa1c843a196fa97725fc07e28aa8fe162fde722 100644 (file)
@@ -45,7 +45,13 @@ endef
 define Package/fbsetroot
 $(call Package/fluxbox/Default)
   DEPENDS:=fluxbox
-  TITLE:=set fluxbox background
+  TITLE:=set fluxbox background colors
+endef
+
+define Package/fbsetbg
+$(call Package/fluxbox/Default)
+  DEPENDS:=fluxbox +x-bkgd-images +eterm
+  TITLE:=set fluxbox background images
 endef
 
 define Build/Configure
@@ -68,12 +74,17 @@ endef
 define Package/fluxbox/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/share/fluxbox/styles/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{fluxbox,fbsetbg} $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/fluxbox $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/fluxbox/{init,keys} $(1)/usr/share/fluxbox/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/fluxbox/styles/* $(1)/usr/share/fluxbox/styles/
        $(CP) files/menu $(1)/usr/share/fluxbox/
 endef
 
+define Package/fbsetbg/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/fbsetbg $(1)/usr/bin/
+endef
+
 define Package/fbsetroot/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/fbsetroot $(1)/usr/bin/
@@ -85,5 +96,6 @@ define Package/fbrun/install
 endef
 
 $(eval $(call BuildPackage,fbrun))
+$(eval $(call BuildPackage,fbsetbg))
 $(eval $(call BuildPackage,fbsetroot))
 $(eval $(call BuildPackage,fluxbox))
index bb0a0e96ee85812b04dcf6a9c60cbf5b6d5a8355..6d7ff3a3a25df95e38c0ef909fe0c0add380341e 100644 (file)
@@ -1 +1,5 @@
+BKGD_IMAGE_PATH=/usr/share/X11/bkgd-images/
+if [ -x `which fbsetbg` ]; then
+       fbsetbg -f ${BKGD_IMAGE_PATH}/default.png
+fi
 fluxbox