[packages] ndisc:
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 13 Jun 2010 00:17:30 +0000 (00:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 13 Jun 2010 00:17:30 +0000 (00:17 +0000)
- update to v0.9.9
- fix compilation by providing dummy WIFCONTINUED() macro
- package rdnssd DNS discovery deamon

SVN-Revision: 21772

ipv6/ndisc/Makefile
ipv6/ndisc/patches/100-favor_bsd.patch
ipv6/ndisc/patches/110-strverscmp.patch
ipv6/ndisc/patches/120-ppoll.patch
ipv6/ndisc/patches/130-wifcontinued.patch [new file with mode: 0644]

index 94778e44a0484110f27248fe43daaf7007ef4945..1044536664f7a5033c76a04f783c83efd0523d26 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ndisc6
-PKG_VERSION:=0.9.8
+PKG_VERSION:=0.9.9
 PKG_RELEASE:=1
-PKG_MD5SUM:=cb8d70564b8d40aae95e19592c6be183
+PKG_MD5SUM:=aab2209fa7bf6b02ed2f49e7b8e9fa18
 
 PKG_SOURCE_URL:=http://www.remlab.net/files/ndisc6/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -56,6 +56,16 @@ define Package/tcptraceroute6/description
 A TCP/IPv6-based traceroute implementation
 endef
 
+define Package/rdnssd
+  $(call Package/ndisc)
+  TITLE:=DNS server discovery deamon
+endef
+
+define Package/rdnssd/description
+A recursive DNS server discovery daemon gathering
+information through stateless IPv6 autoconfiguration (RFC5006)
+endef
+
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -79,6 +89,12 @@ define Package/tcptraceroute6/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tcptraceroute6 $(1)/usr/bin/
 endef
 
+define Package/rdnssd/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/rdnssd/rdnssd $(1)/usr/bin/
+endef
+
 $(eval $(call BuildPackage,ndisc6))
 $(eval $(call BuildPackage,rdisc6))
 $(eval $(call BuildPackage,tcptraceroute6))
+$(eval $(call BuildPackage,rdnssd))
index 4c79abcab8fa51733009bad9cf8fd575c957fee3..ed6090d33a1a3728448640616b94509286ddbe6d 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN ndisc6-0.9.8/src/trace-tcp.c ndisc6-0.9.8.new/src/trace-tcp.c
---- ndisc6-0.9.8/src/trace-tcp.c       2008-05-01 14:52:28.000000000 +0200
-+++ ndisc6-0.9.8.new/src/trace-tcp.c   2009-04-17 15:39:54.000000000 +0200
+--- a/src/trace-tcp.c
++++ b/src/trace-tcp.c
 @@ -24,6 +24,7 @@
  
  #undef _GNU_SOURCE
@@ -9,9 +8,8 @@ diff -urN ndisc6-0.9.8/src/trace-tcp.c ndisc6-0.9.8.new/src/trace-tcp.c
  
  #include <string.h>
  #include <inttypes.h>
-diff -urN ndisc6-0.9.8/src/trace-udp.c ndisc6-0.9.8.new/src/trace-udp.c
---- ndisc6-0.9.8/src/trace-udp.c       2008-05-01 14:52:28.000000000 +0200
-+++ ndisc6-0.9.8.new/src/trace-udp.c   2009-04-17 15:40:36.000000000 +0200
+--- a/src/trace-udp.c
++++ b/src/trace-udp.c
 @@ -24,6 +24,7 @@
  
  #undef _GNU_SOURCE
index 21929585e4c0b5642fb1171ce1c711467ff7009a..ccee8da0bcc1015c26b0841bd39b97c2938ff522 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN ndisc6-0.9.8/rdnssd/Makefile.am ndisc6-0.9.8.new/rdnssd/Makefile.am
---- ndisc6-0.9.8/rdnssd/Makefile.am    2008-05-01 14:52:28.000000000 +0200
-+++ ndisc6-0.9.8.new/rdnssd/Makefile.am        2009-04-17 15:47:51.000000000 +0200
-@@ -27,7 +27,8 @@
+--- a/rdnssd/Makefile.am
++++ b/rdnssd/Makefile.am
+@@ -27,7 +27,8 @@ conf_SCRIPTS = merge-hook
  # rdnssd
  rdnssd_SOURCES = rdnssd.c rdnssd.h \
        icmp.c \
@@ -11,10 +10,9 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.am ndisc6-0.9.8.new/rdnssd/Makefile.am
  rdnssd_LDADD = $(LIBRT) \
                @top_builddir@/compat/libcompat.a
  
-diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
---- ndisc6-0.9.8/rdnssd/Makefile.in    2008-05-01 14:52:45.000000000 +0200
-+++ ndisc6-0.9.8.new/rdnssd/Makefile.in        2009-04-17 15:47:39.000000000 +0200
-@@ -58,7 +58,7 @@
+--- a/rdnssd/Makefile.in
++++ b/rdnssd/Makefile.in
+@@ -58,7 +58,7 @@ CONFIG_CLEAN_FILES =
  am__installdirs = "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(confdir)"
  sbinPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
  PROGRAMS = $(sbin_PROGRAMS)
@@ -23,7 +21,7 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
  rdnssd_OBJECTS = $(am_rdnssd_OBJECTS)
  am__DEPENDENCIES_1 =
  rdnssd_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-@@ -211,7 +211,8 @@
+@@ -213,7 +213,8 @@ conf_SCRIPTS = merge-hook
  # rdnssd
  rdnssd_SOURCES = rdnssd.c rdnssd.h \
        icmp.c \
@@ -33,7 +31,7 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
  
  rdnssd_LDADD = $(LIBRT) \
                @top_builddir@/compat/libcompat.a
-@@ -334,6 +335,7 @@
+@@ -336,6 +337,7 @@ distclean-compile:
  
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/icmp.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/netlink.Po@am__quote@
@@ -41,9 +39,8 @@ diff -urN ndisc6-0.9.8/rdnssd/Makefile.in ndisc6-0.9.8.new/rdnssd/Makefile.in
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rdnssd.Po@am__quote@
  
  .c.o:
-diff -urN ndisc6-0.9.8/rdnssd/strverscmp.c ndisc6-0.9.8.new/rdnssd/strverscmp.c
---- ndisc6-0.9.8/rdnssd/strverscmp.c   1970-01-01 01:00:00.000000000 +0100
-+++ ndisc6-0.9.8.new/rdnssd/strverscmp.c       2009-04-17 15:46:24.000000000 +0200
+--- /dev/null
++++ b/rdnssd/strverscmp.c
 @@ -0,0 +1,131 @@
 +/* Compare strings while treating digits characters numerically.
 +   Copyright (C) 1997, 2000, 2002, 2004 Free Software Foundation, Inc.
index 6a547708563713e591decaad99b43515d7e0d0ae..07b1fca0d9356f71502b699d25cf12a44d2688e6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/compat/fixups.h
 +++ b/compat/fixups.h
-@@ -50,13 +50,25 @@
+@@ -50,13 +50,25 @@ int inet6_rth_add (void *bp, const struc
  # define IPV6_RTHDR_TYPE_0 0
  #endif
  
diff --git a/ipv6/ndisc/patches/130-wifcontinued.patch b/ipv6/ndisc/patches/130-wifcontinued.patch
new file mode 100644 (file)
index 0000000..50ce829
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/src/isatapd.c
++++ b/src/isatapd.c
+@@ -77,6 +77,11 @@
+ #include <netinet/in.h>
+ #include <netinet/icmp6.h>
++/* uclibc does not define WIFCONTINUED(), workaround */
++#ifndef WIFCONTINUED
++#define WIFCONTINUED(wstat) (0)
++#endif
++
+ /* contains Protocol Constants for host and Node (RFCs 4861, 5214) */
+ #include <isatapd.h>