small changes to the way Xorg apps are installed
authorJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 00:16:23 +0000 (00:16 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 00:16:23 +0000 (00:16 +0000)
SVN-Revision: 8897

XOrg/app/common.mk

index a5e4d0db2261cdbd96dc871bf98238bbc1f2fdc2..1c98b1425c3412a291d4fb509009ba1bc013e6c2 100644 (file)
@@ -35,9 +35,16 @@ define Build/Configure
        )
 endef
 
-define Package/${PKG_NAME}/install
+define xinit-X11R7.2/install
+       rm -rf $(1)/usr
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xinit $(1)/usr/bin/xinit
+       cd $(1)/usr/bin/; ln -s xinit startx
+endef
+
+define Package/$(PKG_NAME)/install
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)
        rm -rf $(1)/usr/man/
+       $(call $(PKG_NAME)/install,$(1))
 endef
-