port libtool to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Tue, 18 Jul 2006 12:47:51 +0000 (12:47 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 18 Jul 2006 12:47:51 +0000 (12:47 +0000)
SVN-Revision: 4138

libs/libtool/Makefile [new file with mode: 0644]
libs/libtool/patches/01-force_dlopen_deplibs.patch [new file with mode: 0644]

diff --git a/libs/libtool/Makefile b/libs/libtool/Makefile
new file mode 100644 (file)
index 0000000..d3b03f9
--- /dev/null
@@ -0,0 +1,96 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=1.5.14
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libtool
+PKG_MD5SUM:=049bf67de9b0eb75cd943dafe3d749ec
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libltdl
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A generic dynamic object loading library
+  DESCRIPTION:=A generic dynamic object loading library.
+  URL:=http://www.gnu.org/software/libtool/
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               touch libltdl/configure.ac; \
+               touch libltdl/acinclude.m4; \
+               touch libltdl/aclocal.m4; \
+               touch libltdl/Makefile.in; \
+               touch libltdl/config-h.in; \
+               touch libltdl/configure; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+                       --enable-shared \
+                       --enable-static \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/libltdl/install
+       install -m0755 -d $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libltdl.so.* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ltdl.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(I_LIBLTDL_DEV)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libltdl.{a,so*} $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/ltdl.h \
+               $(STAGING_DIR)/usr/lib/libltdl.{a,so*}
+endef
+
+$(eval $(call BuildPackage,libltdl))
diff --git a/libs/libtool/patches/01-force_dlopen_deplibs.patch b/libs/libtool/patches/01-force_dlopen_deplibs.patch
new file mode 100644 (file)
index 0000000..dfcf56b
--- /dev/null
@@ -0,0 +1,14 @@
+diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
+--- libtool-1.5.14/libltdl/acinclude.m4        2005-02-12 13:20:02.000000000 +0100
++++ libtool-1.5.14.new/libltdl/acinclude.m4    2006-04-17 23:00:24.000000000 +0200
+@@ -6228,10 +6228,8 @@
+     ;;
+   esac
+   ])
+-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
+  AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
+     [Define if the OS needs help to load dependent libraries for dlopen().])
+-fi
+ ])# AC_LTDL_SYS_DLOPEN_DEPLIBS