bind: update to v9.9.4-1
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 10 Oct 2013 13:58:24 +0000 (13:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 10 Oct 2013 13:58:24 +0000 (13:58 +0000)
- update to 9.9.4-1
- refresh patches
- disable ecdsa

Signed-off-by: Thommas Heil <heil@terminal-consulting.de>
SVN-Revision: 38353

net/bind/Makefile
net/bind/patches/001-no-tests.patch
net/bind/patches/002-no-ecdsa-testing.patch [deleted file]

index 433b54e556bc8f02e059ac870ebd34b63fe05430..7b1f8f7174dcf9e89c7b53f94a9f1e2645dfe214 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.9.2-P2
+PKG_VERSION:=9.9.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=2be7763c99b7e7b42ac3a18a267ce1aa
+PKG_MD5SUM:=f69757adc86776daed8e5acb0ee7c0ca
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
@@ -95,6 +95,7 @@ CONFIGURE_ARGS += \
        --enable-epoll=yes \
        --with-gost=no \
        --with-gssapi=no \
+       --with-ecdsa=no \
        --with-readline=no
 
 CONFIGURE_VARS += \
index 5fc17875cdd65398afc91cc91693fd98a7665ac4..c969c5e9684250f16a3c24ddef2cd6373e3c2a40 100644 (file)
@@ -1,16 +1,20 @@
---- a/bin/Makefile.in
-+++ b/bin/Makefile.in
+Index: bind-9.9.4/bin/Makefile.in
+===================================================================
+--- bind-9.9.4.orig/bin/Makefile.in
++++ bind-9.9.4/bin/Makefile.in
 @@ -19,7 +19,7 @@ srcdir =     @srcdir@
  VPATH =               @srcdir@
  top_srcdir =  @top_srcdir@
  
--SUBDIRS =     named rndc dig dnssec tests tools nsupdate \
+-SUBDIRS =     named rndc dig dnssec tools tests nsupdate \
 +SUBDIRS =     named rndc dig dnssec tools nsupdate \
                check confgen @PYTHON_TOOLS@ @PKCS11_TOOLS@
  TARGETS =
  
---- a/lib/Makefile.in
-+++ b/lib/Makefile.in
+Index: bind-9.9.4/lib/Makefile.in
+===================================================================
+--- bind-9.9.4.orig/lib/Makefile.in
++++ bind-9.9.4/lib/Makefile.in
 @@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
  # Attempt to disable parallel processing.
  .NOTPARALLEL:
diff --git a/net/bind/patches/002-no-ecdsa-testing.patch b/net/bind/patches/002-no-ecdsa-testing.patch
deleted file mode 100644 (file)
index 901e246..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -763,40 +763,6 @@ esac
-                       AC_MSG_RESULT(no)
-               fi
--              AC_CHECK_FUNCS(EVP_sha256 EVP_sha384 EVP_sha512)
--
--              AC_MSG_CHECKING(for OpenSSL ECDSA support)
--              have_ecdsa=""
--              AC_TRY_RUN([
--#include <stdio.h>
--#include <openssl/ecdsa.h>
--#include <openssl/objects.h>
--int main() {
--      EC_KEY *ec256, *ec384;
--
--#if !defined(HAVE_EVP_SHA256) || !defined(HAVE_EVP_SHA384)
--      return (1);
--#endif
--      ec256 = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1);
--      ec384 = EC_KEY_new_by_curve_name(NID_secp384r1);
--      if (ec256 == NULL || ec384 == NULL)
--              return (2);
--      return (0);
--}
--],
--              [AC_MSG_RESULT(yes)
--              have_ecdsa="yes"],
--              [AC_MSG_RESULT(no)
--              have_ecdsa="no"])
--              case $have_ecdsa in
--              yes)
--                      OPENSSL_ECDSA="yes"
--                      AC_DEFINE(HAVE_OPENSSL_ECDSA)
--                      ;;
--              *)
--                      ;;
--              esac
--
-               AC_MSG_CHECKING(for OpenSSL GOST support)
-               have_gost=""
-               AC_TRY_RUN([