packages: add live/openrtsp package (thanks to Neel Banerjee)
authorNicolas Thill <nico@openwrt.org>
Wed, 14 Dec 2011 10:16:31 +0000 (10:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 14 Dec 2011 10:16:31 +0000 (10:16 +0000)
SVN-Revision: 29524

net/live/Makefile [new file with mode: 0644]
net/live/patches/101-openwrt.patch [new file with mode: 0644]

diff --git a/net/live/Makefile b/net/live/Makefile
new file mode 100644 (file)
index 0000000..1d79414
--- /dev/null
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=live
+PKG_VERSION:=2011.12.02
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.live555.com/liveMedia/public/
+PKG_MD5SUM:=4f10d93d33f6714a980fd1655ead69cd
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/openrtsp
+  SECTION:=video
+  CATEGORY:=Video Streaming
+  TITLE:=live555 streaming libraries and testProgs
+  URL:=http://www.live555.com/
+  DEPENDS:=+libstdcpp
+endef
+
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); \
+               $(SED) 's/@CROSS_COMPILE@/$(TARGET_CROSS)/g' \
+                   -e 's/@CFLAGS@/$(TARGET_CFLAGS)/g' \
+                   config.OpenWrt; \
+               ./genMakefiles OpenWrt; \
+       )
+endef
+
+define Package/openrtsp/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/testProgs/openRTSP $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,openrtsp))
diff --git a/net/live/patches/101-openwrt.patch b/net/live/patches/101-openwrt.patch
new file mode 100644 (file)
index 0000000..dffedbc
--- /dev/null
@@ -0,0 +1,23 @@
+--- /dev/null
++++ b/config.OpenWrt
+@@ -0,0 +1,20 @@
++CROSS_COMPILE=        @CROSS_COMPILE@
++COMPILE_OPTS =        $(INCLUDES) -I. @CFLAGS@ -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -DLOCALE_NOT_USED
++C =            c
++C_COMPILER =        $(CROSS_COMPILE)gcc
++CFLAGS +=        $(COMPILE_OPTS)
++C_FLAGS = $(CFLAGS)
++CPP =            cpp
++CPLUSPLUS_COMPILER =    $(CROSS_COMPILE)g++
++CPLUSPLUS_FLAGS =    $(COMPILE_OPTS) -Wall -DBSD=1
++CPLUSPLUS_FLAGS += $(CPPFLAGS) -fexceptions
++OBJ =            o
++LINK =            $(CROSS_COMPILE)g++ -o
++LINK_OPTS =        -L. $(LDFLAGS)
++CONSOLE_LINK_OPTS =    $(LINK_OPTS)
++LIBRARY_LINK =        $(CROSS_COMPILE)ar cr 
++LIBRARY_LINK_OPTS =    
++LIB_SUFFIX =            a
++LIBS_FOR_CONSOLE_APPLICATION = $(CXXLIBS)
++LIBS_FOR_GUI_APPLICATION = $(LIBS_FOR_CONSOLE_APPLICATION)
++EXE =